summaryrefslogtreecommitdiff
path: root/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild')
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..e1df14facd06
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/zeppelin
+ acct-user/zeppelin
+ >=virtual/jdk-1.8"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${P}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}