summaryrefslogtreecommitdiff
path: root/www-apps/ttyd/ttyd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
commiteecd75a62239257eb2235bfe8697c73887a9a080 (patch)
tree8c01b16cb32e1a22ad5b8efe32d843c96cfa2ff2 /www-apps/ttyd/ttyd-9999.ebuild
parent7b97d94d4769a556456398d66819200655c4d76c (diff)
gentoo auto-resync : 29:01:2024 - 00:57:18
Diffstat (limited to 'www-apps/ttyd/ttyd-9999.ebuild')
-rw-r--r--www-apps/ttyd/ttyd-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/www-apps/ttyd/ttyd-9999.ebuild b/www-apps/ttyd/ttyd-9999.ebuild
index adbcac55b7f7..3fdbd114e567 100644
--- a/www-apps/ttyd/ttyd-9999.ebuild
+++ b/www-apps/ttyd/ttyd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,20 +20,22 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="mbedtls"
DEPEND="
dev-libs/json-c:=
dev-libs/libuv:=
- net-libs/libwebsockets:=[libuv,ssl]
+ net-libs/libwebsockets:=[libuv,mbedtls=,ssl]
sys-libs/zlib:=
+ !mbedtls? ( dev-libs/openssl:= )
"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
src_install() {
- dobin ../${P}_build/${PN}
- doman man/*.1
+ cmake_src_install
+
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
newconfd "${FILESDIR}/${PN}.confd" "${PN}"
systemd_dounit "${FILESDIR}"/${PN}.service