summaryrefslogtreecommitdiff
path: root/www-apps/ttyd/ttyd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 05:29:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 05:29:57 +0100
commit4e777c0133d093c9c8b992c92e0f244e2055bf71 (patch)
treed6fbeed2e9eb1b486babf5d6f4886da4bdba4dbc /www-apps/ttyd/ttyd-9999.ebuild
parent6f57e716c7968def6387f9db258e883125bab84f (diff)
gentoo auto-resync : 05:05:2023 - 05:29:57
Diffstat (limited to 'www-apps/ttyd/ttyd-9999.ebuild')
-rw-r--r--www-apps/ttyd/ttyd-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-apps/ttyd/ttyd-9999.ebuild b/www-apps/ttyd/ttyd-9999.ebuild
new file mode 100644
index 000000000000..14c795388490
--- /dev/null
+++ b/www-apps/ttyd/ttyd-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+MY_PV="$(ver_rs 3 '-')"
+
+DESCRIPTION="ttyd, a simple command-line tool for sharing terminal over the web"
+HOMEPAGE="https://github.com/tsl0922/ttyd"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/tsl0922/ttyd.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tsl0922/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="dev-util/cmake"
+
+DEPEND="
+ dev-vcs/git:=
+ dev-libs/json-c:=
+ dev-libs/libuv:=
+ net-libs/libwebsockets:=[libuv,ssl]
+ sys-libs/zlib:=
+ "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ dobin ../${P}_build/${PN}
+ doman man/*.1
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}