summaryrefslogtreecommitdiff
path: root/www-apps/trickster/trickster-1.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /www-apps/trickster/trickster-1.1.5.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'www-apps/trickster/trickster-1.1.5.ebuild')
-rw-r--r--www-apps/trickster/trickster-1.1.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/trickster/trickster-1.1.5.ebuild b/www-apps/trickster/trickster-1.1.5.ebuild
new file mode 100644
index 000000000000..8f4e9be4ae1f
--- /dev/null
+++ b/www-apps/trickster/trickster-1.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Dashboard Accelerator for Prometheus"
+HOMEPAGE="https://github.com/tricksterproxy/trickster"
+VENDOR_URI="https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
+SRC_URI="https://github.com/tricksterproxy/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${VENDOR_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ acct-group/trickster
+ acct-user/trickster"
+ DEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ default
+ mv ../vendor .
+}
+
+src_compile() {
+ set -- go build -mod vendor ./cmd/trickster
+ echo $@
+ "$@" || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+dodoc -r conf docs/*
+ systemd_dounit conf/trickster.service
+ insinto /etc/trickster
+ doins "${FILESDIR}"/${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}