summaryrefslogtreecommitdiff
path: root/www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
commitf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (patch)
treee16b2f573ffa54d21accbf0dfc3647b47b0578c8 /www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild
parente9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (diff)
gentoo auto-resync : 10:08:2022 - 20:18:34
Diffstat (limited to 'www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild')
-rw-r--r--www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild b/www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild
new file mode 100644
index 000000000000..a3d2abfcc0bc
--- /dev/null
+++ b/www-apps/sonarr/sonarr-3.0.9.1549-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="https://download.sonarr.tv/v3/main/${PV}/Sonarr.main.${PV}.linux.tar.gz"
+
+DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
+HOMEPAGE="https://www.sonarr.tv"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/sonarr
+ acct-user/sonarr
+ >=dev-lang/mono-6.6.0.161
+ media-video/mediainfo
+ dev-db/sqlite"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Sonarr"
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init-r1" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/${PN}" || die "Install failed!"
+
+ exeinto "/opt/${PN}"
+ doexe "${FILESDIR}/Sonarr"
+
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}@.service"
+}