summaryrefslogtreecommitdiff
path: root/www-apps/postfixadmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /www-apps/postfixadmin
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/Manifest2
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.2.4.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index 94ef62339ae8..514b648c0009 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,4 +1,6 @@
AUX postinstall-en-2.3.txt 1827 BLAKE2B 49402566ddf6981cf0226f6a963fdd2c482957903583807f5c42731dfd5b4aea56de7d1ebd47ab6909f12492bd5e7a788322e0b2d80e15d883483a080f8fe11c SHA512 59e304d63830227b1619ed1299e9b61f5b6e534cb03da4d3a0e35a0fe727ccf2d994a034bd12d515bba4f8a6a8ca513cf2131c031fa63f85906639aca159993a
DIST postfixadmin-3.2.3.tar.gz 1330423 BLAKE2B 95aeb1a5f3b1dca2ce60e3e6a974f59b8c0e649c185149adb5d1259477cfe113b59c06f825cc9e1a38741260f111eaa3eef5a26ca44260aea2277b16f1f54543 SHA512 d44addb9a3ca830caf55b603363054df561d659957f21cab7523465ebf02ca18abe7fcf298fe718d957d0b7bf5613e2dde69c78c26e0f7f6f595d79b28fe08ab
+DIST postfixadmin-3.2.4.tar.gz 1331185 BLAKE2B a16df15f6376f9024114c5870174168e5f3d4b0f52d8759db0d83cb4c05fbbe2949056de0ca5ce097652588b777d59f08bcc2555577c95fbd7f2ebc5dd7f357f SHA512 2bd7ae05addbaf3c6c7eebea16ec1e21b2c67c8e6161446ed82a9553c26c04e19c1ec9ce248a9b9df504df56d309590259e6f04907b04b593548028b40e40d47
EBUILD postfixadmin-3.2.3.ebuild 2768 BLAKE2B 66416892e98549be73a888f6ec88035b4bb50ec522bbdcb61fc982c76c348b3ab4194938b9b823757c8a45f135fdee5ff1cbaee9312df2d1e8e664a1f2b331b1 SHA512 ce03e644d2b0a6a9a7ffeee1fa374ea255808e7ab901564c08eccf1835e99da93bae94f674b4ed5440563712cd6e8b0582b010fff9a7492184a2aa5d0664ff46
+EBUILD postfixadmin-3.2.4.ebuild 2770 BLAKE2B 1bf903c27562ec4f4fed7ddd072513d7de0e124cd352d69440da3940ba6d65bb9e0ecfd0acfde51ef238852d6b28c82dba5cb56f39b2ab8531b4db3dc75c71f5 SHA512 f0bc5a023e67253a63594ea9a819703e1f79ab6d0de463f2c322bc5bcd450143ee97310111b733591d56b7d1373917418d94868591be61b0d28423b996035f3d
MISC metadata.xml 536 BLAKE2B 0ec01f47f106656e1b98ca14d8b531597a34cfb2fd261c93c775d7dd3b0a08155e9e912a20a2330946697418898ed08d9be6f8409edb5e1ef6009cafddde2437 SHA512 4657f3ae892ad55572ac39f23cebcef58480d4ff608150c75d2cf3f0046b5e0a2861f9bf8dfffd45aef580675feae11a05297a7a99f63997d43ab703372ddf4a
diff --git a/www-apps/postfixadmin/postfixadmin-3.2.4.ebuild b/www-apps/postfixadmin/postfixadmin-3.2.4.ebuild
new file mode 100644
index 000000000000..b998b917d863
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.2.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ docinto /usr/share/doc/${PF}/
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}