summaryrefslogtreecommitdiff
path: root/www-apps/piwigo/piwigo-13.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
commit0374a8491c853f9331b95ed2a38e688e4d2edce5 (patch)
tree563dd0e0f6ee34895358db0f88d683934ca21756 /www-apps/piwigo/piwigo-13.2.0.ebuild
parent070c77515d1406e762e9e344856546f0a15765b6 (diff)
gentoo auto-resync : 18:11:2022 - 12:58:32
Diffstat (limited to 'www-apps/piwigo/piwigo-13.2.0.ebuild')
-rw-r--r--www-apps/piwigo/piwigo-13.2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/piwigo/piwigo-13.2.0.ebuild b/www-apps/piwigo/piwigo-13.2.0.ebuild
new file mode 100644
index 000000000000..646c95f17d2a
--- /dev/null
+++ b/www-apps/piwigo/piwigo-13.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}