summaryrefslogtreecommitdiff
path: root/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild')
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
new file mode 100644
index 000000000000..a40a1a7ca93a
--- /dev/null
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I $(pg_config --includedir)" \
+ LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)"
+}
+
+src_install() {
+ dobin lf_update lf_update_suggestion_order lf_export
+ insinto /usr/share/${PN}
+ doins -r {core,init,demo,test}.sql update
+ dodoc README "${FILESDIR}"/postinstall-en.txt
+}