summaryrefslogtreecommitdiff
path: root/www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild')
-rw-r--r--www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild b/www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild
new file mode 100644
index 000000000000..456e51255cd7
--- /dev/null
+++ b/www-apps/jekyll-coffeescript/jekyll-coffeescript-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/jekyll/jekyll-coffeescript/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A CoffeeScript Converter for Jekyll"
+HOMEPAGE="https://github.com/jekyll/jekyll-coffeescript"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "/^RSpec/i \
+ require 'jekyll'"\
+ -e "/^RSpec/i \
+ require 'jekyll-coffeescript'" spec/spec_helper.rb || die
+}
+
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2
+ >=dev-ruby/coffee-script-source-1.11.1"
+ruby_add_bdepend "test? ( www-apps/jekyll )"