summaryrefslogtreecommitdiff
path: root/www-apps/gitit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /www-apps/gitit
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'www-apps/gitit')
-rw-r--r--www-apps/gitit/Manifest1
-rw-r--r--www-apps/gitit/gitit-0.13.0.0-r1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/gitit/Manifest b/www-apps/gitit/Manifest
index 97f2525265d2..414e2249f58b 100644
--- a/www-apps/gitit/Manifest
+++ b/www-apps/gitit/Manifest
@@ -1,3 +1,4 @@
DIST gitit-0.13.0.0.tar.gz 274691 BLAKE2B 74ef7d4a73356a2be7531fa22faf6ebd2f5a2edf9ce40909cff31756d93e1bea8e563d953b6c3fe0ea30fa98d13dee21aa7331bbb281fcfd476b2de90cd0accb SHA512 dce06c73813a71df4e9896e62f611906de708a5186ace2ba4679bd53bae48495ced5b888febb65a395cef3b11ecb595dfca079b1c3ed24fb464aa997e710ab1e
+EBUILD gitit-0.13.0.0-r1.ebuild 3374 BLAKE2B 8d49f97d86f0c3e25ff0f4a4ac991a48c03e401ada4f5ef4146c4334b91ec421eb687db5a18923d0c3eba0051be0fedf024352c5a2ec930920185c24ffa01f77 SHA512 2cbcde220e6b772e593a45a7cbbf9252612be83c0cc6259e95b38f61c02d54be3617ce7d67ae89ebe67ad82caeae91474fd7943062fbc8eb5ba551865ea6b199
EBUILD gitit-0.13.0.0.ebuild 3239 BLAKE2B fdf70a2ba2dbe3091acf3fe692f359a4696b22dcbf1ec6bd3a7797db00504c0342b9390dcbcfb28e197ae6601feaa08a9d158c8035952d4708c60407ae35b274 SHA512 57e7289d0303e2516259c7083486a553304674ebc880269602b80e0838308583ccb21f71e3c3b8f58df483dd5124933d980fedfea7d9e1e0fbb1350164e13e03
MISC metadata.xml 1345 BLAKE2B 0647bf06da38617360a67c71cecde3b5337073b6dcf0413d3f962dc0e69625c4b0e2a0919c1cbc93ad88d5e38748a8c96d16704aaf76bb547da8c503f18ddb36 SHA512 fc120ee0cecb42984179def72c1d91bba405a7c91357ffa934e9f98edb224fb9a147be0a5beab49c90bc47e0adfcd1c01dbc16998da9c151b348d8c78ab6b0ef
diff --git a/www-apps/gitit/gitit-0.13.0.0-r1.ebuild b/www-apps/gitit/gitit-0.13.0.0-r1.ebuild
new file mode 100644
index 000000000000..e24c23a2a38e
--- /dev/null
+++ b/www-apps/gitit/gitit-0.13.0.0-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Wiki using happstack, git or darcs, and pandoc"
+HOMEPAGE="https://hackage.haskell.org/package/gitit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins"
+
+RDEPEND=">=app-text/pandoc-2.9:=[profile?]
+ >=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-html-0.4:=[profile?] <dev-haskell/blaze-html-0.10:=[profile?]
+ >=dev-haskell/configfile-1:=[profile?]
+ >=dev-haskell/doctemplates-0.7.1:=[profile?]
+ >=dev-haskell/feed-1.0:=[profile?] <dev-haskell/feed-1.4:=[profile?]
+ >=dev-haskell/filestore-0.6.4:=[profile?] <dev-haskell/filestore-0.7:=[profile?]
+ >=dev-haskell/happstack-server-7.5:=[profile?]
+ >=dev-haskell/hoauth2-1.3.0:=[profile?]
+ >=dev-haskell/hslogger-1:=[profile?]
+ >=dev-haskell/hstringtemplate-0.6:=[profile?] <dev-haskell/hstringtemplate-0.9:=[profile?]
+ >=dev-haskell/http-4000.0:=[profile?]
+ >=dev-haskell/http-client-tls-0.2.2:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-conduit-2.1.6:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/json-0.4:=[profile?] <dev-haskell/json-0.11:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.8.1:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/pandoc-types-1.20:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/recaptcha-0.1:=[profile?]
+ dev-haskell/safe:=[profile?]
+ >dev-haskell/sha-1:=[profile?]
+ >=dev-haskell/skylighting-0.8.2.3:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/tagsoup-0.13:=[profile?] <dev-haskell/tagsoup-0.15:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/uri-bytestring-0.2.3.3:=[profile?]
+ >=dev-haskell/url-2.1:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/uuid-1.3:=[profile?] <dev-haskell/uuid-1.4:=[profile?]
+ dev-haskell/xhtml:=[profile?]
+ >=dev-haskell/xml-1.3.5:=[profile?]
+ >=dev-haskell/xml-conduit-1.5:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?]
+ >=dev-haskell/xss-sanitize-0.3:=[profile?] <dev-haskell/xss-sanitize-0.4:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ plugins? ( dev-haskell/ghc-paths:=[profile?]
+ >=dev-lang/ghc-8.0.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'aeson >= 0.7 && < 1.5' 'aeson >= 0.7' \
+ 'pandoc >= 2.9 && < 2.10' 'pandoc >= 2.9' \
+ 'pandoc-types >= 1.20 && < 1.21' 'pandoc-types >= 1.20' \
+ 'skylighting >= 0.8.2.3 && < 0.9' 'skylighting >= 0.8.2.3' \
+ 'hoauth2 >= 1.3.0 && < 1.12' 'hoauth2 >= 1.3.0' \
+ 'happstack-server >= 7.5 && < 7.7' 'happstack-server >= 7.5'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag plugins plugins)
+}