summaryrefslogtreecommitdiff
path: root/www-apps/element/element-1.11.59.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 23:42:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 23:42:06 +0000
commitc8042d10e135808d5f2b48867bc291e00664b99b (patch)
tree7ff539056fa93b5d71b38241122ac9d6566cf672 /www-apps/element/element-1.11.59.ebuild
parent7c58ecff5764af03b4c65f4115d7b9474e3a5717 (diff)
gentoo auto-resync : 02:03:2024 - 23:42:06
Diffstat (limited to 'www-apps/element/element-1.11.59.ebuild')
-rw-r--r--www-apps/element/element-1.11.59.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/element/element-1.11.59.ebuild b/www-apps/element/element-1.11.59.ebuild
new file mode 100644
index 000000000000..d83478c13073
--- /dev/null
+++ b/www-apps/element/element-1.11.59.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://element.io/"
+SRC_URI="https://github.com/vector-im/element-web/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+need_httpd
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/home
+ dodir "${MY_HTDOCSDIR}"/sites
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/home
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites
+ #webapp_configfile "${MY_HTDOCSDIR}"/config.json
+
+ webapp_src_install
+}