summaryrefslogtreecommitdiff
path: root/www-apps/element/element-1.11.50.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 04:34:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 04:34:22 +0000
commit9f644c082e09048b176cdc65d87a0e6df3f18f2f (patch)
tree7bf6f585eeedfff22738cba65fa5183a7e34549b /www-apps/element/element-1.11.50.ebuild
parent2d37d4dc50650d8de650e8a476233f57d972cdf6 (diff)
gentoo auto-resync : 24:11:2023 - 04:34:22
Diffstat (limited to 'www-apps/element/element-1.11.50.ebuild')
-rw-r--r--www-apps/element/element-1.11.50.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/element/element-1.11.50.ebuild b/www-apps/element/element-1.11.50.ebuild
new file mode 100644
index 000000000000..b0b3474a9886
--- /dev/null
+++ b/www-apps/element/element-1.11.50.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://element.io/"
+SRC_URI="https://github.com/vector-im/element-web/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+need_httpd
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/home
+ dodir "${MY_HTDOCSDIR}"/sites
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/home
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites
+ #webapp_configfile "${MY_HTDOCSDIR}"/config.json
+
+ webapp_src_install
+}