summaryrefslogtreecommitdiff
path: root/www-apps/drraw/drraw-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/drraw/drraw-2.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/drraw/drraw-2.0.1.ebuild')
-rw-r--r--www-apps/drraw/drraw-2.0.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/drraw/drraw-2.0.1.ebuild b/www-apps/drraw/drraw-2.0.1.ebuild
new file mode 100644
index 000000000000..db9c7e1cb1c1
--- /dev/null
+++ b/www-apps/drraw/drraw-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit webapp
+
+DESCRIPTION="drraw is a simple web based presentation front-end for RRDtool"
+HOMEPAGE="http://web.taranis.org/drraw"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/CGI
+ >=net-analyzer/rrdtool-1.0.47"
+
+need_httpd_cgi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s|/usr/local/bin/perl|/usr/bin/perl|" drraw.cgi
+ sed -i \
+ -e "s|/somewhere/drraw/saved|/tmp|" \
+ -e "s|/somewhere/drraw/tmp|/tmp|" \
+ drraw.conf
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGES INSTALL README.EVENTS WISHLIST
+ rm CHANGES INSTALL README.EVENTS WISHLIST
+
+ insinto "${MY_CGIBINDIR}"
+ doins drraw.conf
+
+ exeinto "${MY_CGIBINDIR}"
+ doexe drraw.cgi
+
+ insinto "${MY_ICONSDIR}"
+ doins icons/*.gif
+
+ webapp_configfile "${MY_CGIBINDIR}"/drraw.conf
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}