summaryrefslogtreecommitdiff
path: root/www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
commitaeb00d494a88844a67a5483be221169c5cc2c4be (patch)
tree31cadd24d79954c602995af6abb621e764729674 /www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild
parent1c646fe0f6db3b97a61ac9d93f96c0eee5ef517a (diff)
gentoo auto-resync : 06:03:2024 - 07:06:02
Diffstat (limited to 'www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild')
-rw-r--r--www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild b/www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild
new file mode 100644
index 000000000000..ff9ba50fc766
--- /dev/null
+++ b/www-apps/chromedriver-bin/chromedriver-bin-122.0.6261.111.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# See https://googlechromelabs.github.io/chrome-for-testing/#stable for URLs
+DESCRIPTION="WebDriver for Chrome"
+HOMEPAGE="https://sites.google.com/corp/chromium.org/driver/"
+SRC_URI="amd64? ( https://storage.googleapis.com/chrome-for-testing-public/${PV}/linux64/chromedriver-linux64.zip -> ${P}.linux64.zip )"
+S="${WORKDIR}/chromedriver-linux64"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* amd64"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ sys-libs/glibc
+ www-client/google-chrome
+ !www-client/chromium
+"
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="usr/bin/chromedriver"
+
+src_install() {
+ dobin chromedriver
+}