summaryrefslogtreecommitdiff
path: root/www-apache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /www-apache
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/Manifest.gzbin7089 -> 7252 bytes
-rw-r--r--www-apache/mod_maxminddb/Manifest4
-rw-r--r--www-apache/mod_maxminddb/files/70_mod_maxminddb.conf3
-rw-r--r--www-apache/mod_maxminddb/metadata.xml16
-rw-r--r--www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild40
-rw-r--r--www-apache/mod_qos/Manifest2
-rw-r--r--www-apache/mod_qos/mod_qos-11.65.ebuild61
7 files changed, 126 insertions, 0 deletions
diff --git a/www-apache/Manifest.gz b/www-apache/Manifest.gz
index 35b889a45f90..122bebdef439 100644
--- a/www-apache/Manifest.gz
+++ b/www-apache/Manifest.gz
Binary files differ
diff --git a/www-apache/mod_maxminddb/Manifest b/www-apache/mod_maxminddb/Manifest
new file mode 100644
index 000000000000..1e629b4671d7
--- /dev/null
+++ b/www-apache/mod_maxminddb/Manifest
@@ -0,0 +1,4 @@
+AUX 70_mod_maxminddb.conf 87 BLAKE2B b50eb32c9cbf88f63bd9b0d5d12d13a83d7a4cb87ff3ad96bbc06825aa2b144d9ae6c09f0abd2c4004ec7a88b9156ba6b5bf5b6fbf2ede947dae2f46a03c5b30 SHA512 e9137211ea71a52a1010cd022cc5bdc3ae967a02eeb5cbe8339239251f3d2fdb14aba03ba66dea1071f513947e26598cd228e455e92df5a41a5016e5112b5ea5
+DIST mod_maxminddb-1.2.0.tar.gz 101465 BLAKE2B a0f9673560851726e7e85b3c6a5ef3e9004854e79a72bb14446bd68eec59ed8befb3bc27d7e7f031c69708ab54984c9f7537e5d55616be9f7ef1b92e2de61ccd SHA512 739c3c9b136fd3ce784e0a81c82a26a188e7d07435c1381ba359b2e159a721d072cb04310f2ce2a38953a8918fec686025bac6c140048a1afc035c0b8e449483
+EBUILD mod_maxminddb-1.2.0.ebuild 905 BLAKE2B 7d3263f2aac6e200b3118300bab26fda18d110960205e3b433485ee38c6d7671d33249d2290a3fa0f72018b2328eb8c0085381b9397d371629841be89bdc66e9 SHA512 294db9d999ede6165f20de093f9c8507800170856cbec5ccb5fc9a80869ad5e8cbc6873be669f894ad10342a3f80de8b4f3c1a69a5384dc6ff4baf7b9bd70411
+MISC metadata.xml 483 BLAKE2B 72cbf0490ccad2edbbd3f100c788033971252a9e0d29e83ea27fe5965b3c1f6c76bb27ebabe75bb7bbd2d6a6d9c40039ac213bfaa8e1df9a4a17a901ee8c6e59 SHA512 4722e9eaaf1971a864884ab858f9c113a89e06d1fc8490c9a852285130b0ed9c708c5e039b7974f137d6b4019e581bd69c2fbaa9ebbc0451b5fd874227088d77
diff --git a/www-apache/mod_maxminddb/files/70_mod_maxminddb.conf b/www-apache/mod_maxminddb/files/70_mod_maxminddb.conf
new file mode 100644
index 000000000000..80d1ba92f10d
--- /dev/null
+++ b/www-apache/mod_maxminddb/files/70_mod_maxminddb.conf
@@ -0,0 +1,3 @@
+<IfDefine MAXMINDDB>
+ LoadModule maxminddb_module modules/mod_maxminddb.so
+</IfDefine>
diff --git a/www-apache/mod_maxminddb/metadata.xml b/www-apache/mod_maxminddb/metadata.xml
new file mode 100644
index 000000000000..16b10cec63ed
--- /dev/null
+++ b/www-apache/mod_maxminddb/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ <description>Proxy</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maxmind/mod_maxminddb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild b/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild
new file mode 100644
index 000000000000..c0d42244f01a
--- /dev/null
+++ b/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+DESCRIPTION="MaxMind DB Apache Module"
+HOMEPAGE="https://maxmind.github.io/mod_maxminddb/"
+SRC_URI="https://github.com/maxmind/mod_maxminddb/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libmaxminddb:="
+RDEPEND="${DEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ # skipping this results in:
+ # Cannot load modules/mod_maxminddb.so into server:
+ # /usr/lib64/apache2/modules/mod_maxminddb.so: undefined symbol: MMDB_aget_value
+ # because mod_maxminddb.so is not linked with libmaxminddb
+ emake
+}
+
+src_install() {
+ APACHE2_MOD_CONF="70_${PN}"
+ APACHE2_MOD_DEFINE="MAXMINDDB"
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+
+ apache-module_src_install
+}
diff --git a/www-apache/mod_qos/Manifest b/www-apache/mod_qos/Manifest
index db17c708ef88..ac300e6f9d42 100644
--- a/www-apache/mod_qos/Manifest
+++ b/www-apache/mod_qos/Manifest
@@ -1,4 +1,6 @@
AUX 10_mod_qos.conf 97 BLAKE2B d3dfe5296b89ef35b09e6b9a0d272c3fcfd66ceb54e2405c31d67a703a68f7362f5bd5340d3634d8f2c09cc8b825a8ef715c0b99430df5b9b98355c2ff4e516b SHA512 eafdbc3ae2f33a7e2bb55e59c311e79688c3ecabdd12247a5f68a9c00c46b84c709139f124cdccc5fd7b3d792b23a94ce37a8d27835d70c521ad6212d4e761c2
DIST mod_qos-11.61.tar.gz 1242978 BLAKE2B d784538e516abda338230ae9f2580217e3727f8aa22e5d1e881d605ade06444753c9f393a16ef8c683422bb989434b1152aa06955c3f5ba5b38e486d3cc4571b SHA512 c34a970e869238a1340a4bf32f3b21ac3e19cfb65a809989c45100aa1c3559ce0a5f5c30e6366f6d65ef04ad6fc1be73f80a9fc18b7a6a164912618cce6383a8
+DIST mod_qos-11.65.tar.gz 1247087 BLAKE2B 145af39814f974855520415c3bf114aa11ac9002784feace877c9777311fb77fa798fe5f61c7b63201ab5dd6d9582a1d141f421c7215ba3271a29cece13d02b0 SHA512 7a4363b7b5e31968188f2668003d88538134456c3e6eeaff7d200ebf46064139561da6adf9b96678f349bd296f2c502a2d2c9bfb8ae12f7c78e3edbe5c13de3b
EBUILD mod_qos-11.61.ebuild 1016 BLAKE2B 66b80b9c56cf82ec6c01b73ad660ecf95363b2450513868c07c36868cb6327731401e88edeb010bf51516ce78e59eb2919ceaea3957fc9d2bcfaa5612c6ae9bb SHA512 c647eec700392c45827bc859a7c04d15ff7f6af7d93bc9ab77947d0b5e5170aa278d224d150596d864d3bd2cc7ea7120e3752a3be5e2a173775632483dc612e3
+EBUILD mod_qos-11.65.ebuild 1163 BLAKE2B 3937f41aed391c7b15467f61014332da33aa513136a2435d8de4985fccb4f0b4dd829ce1983fcec4068d986a46e629dfece57541f91003a8caa2460429617b0f SHA512 0ab9aea2e74a785701a6dcd77d1a15ff02188249a11a8c7f4ef671e14d9fbda9cc72f85cb7ddbbde5ebab14ea61ed749a8a6e737a9ef1b6e49950424a7d3bc16
MISC metadata.xml 244 BLAKE2B e543aaf02e6b5efa49dbd6e952f6d824548558cb94f91e489f81b70c2f13cd0f54c3388b3b540b50e54e9e78be5f8084f331ee720b8b49fa8aeeb1179a2384ca SHA512 8757fe5e361f5e4214eaf304d5d9d57bc542f1eba248fe4dfc44310d95af160e8c04ad72723b3bf7afd3075ed2f6d58e4bd28643fff37fcd8d6e0134dc147dc7
diff --git a/www-apache/mod_qos/mod_qos-11.65.ebuild b/www-apache/mod_qos/mod_qos-11.65.ebuild
new file mode 100644
index 000000000000..765632d044a6
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.65.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libpcre:3
+ dev-libs/openssl:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+"
+DEPEND="${DEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+src_prepare() {
+ default
+
+ pushd "${S}"/tools &>/dev/null || die
+ eautoreconf
+ popd &>/dev/null || die
+}
+
+src_configure() {
+ pushd "${S}"/tools &>/dev/null || die
+ econf
+ popd &>/dev/null || die
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}"/tools
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ pushd "${S}"/tools &>/dev/null || die
+ apache-module_src_install
+ popd &>/dev/null || die
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}"/tools install DESTDIR="${D}"
+
+ # installing html documentation
+ dohtml -r -x *.txt "${S}"/doc/
+}