summaryrefslogtreecommitdiff
path: root/www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild
new file mode 100644
index 000000000000..921251693813
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.5.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
+}
+
+src_compile() {
+ default
+}