summaryrefslogtreecommitdiff
path: root/www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild')
-rw-r--r--www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild b/www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
new file mode 100644
index 000000000000..11e4d4c075f9
--- /dev/null
+++ b/www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Look up Apache ~user directories in an LDAP directory"
+HOMEPAGE="http://horde.net/~jwm/software/${PN}/"
+SRC_URI="http://horde.net/~jwm/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl"
+
+DEPEND="net-nds/openldap
+ ssl? ( dev-libs/openssl )"
+
+# The module will compile fine without apache[ldap], but Apache will
+# crash if you try to load ${PN} without mod_ldap loaded. The funny-
+# looking atom was taken from depend.apache.eclass (need_apache2).
+RDEPEND="${DEPEND}
+ =www-servers/apache-2*[ldap]"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="LDAP LDAP_USERDIR"
+
+DOCFILES="DIRECTIVES README user-ldif"
+
+# Don't try to get away without this, even though it causes some deps to
+# be repeated.
+need_apache2