summaryrefslogtreecommitdiff
path: root/www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild')
-rw-r--r--www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild b/www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild
new file mode 100644
index 000000000000..b660fe032275
--- /dev/null
+++ b/www-apache/mod_fcgid/mod_fcgid-2.3.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit apache-module eutils multilib
+
+DESCRIPTION="Binary-compatible alternative to mod_fastcgi with better process management"
+HOMEPAGE="https://httpd.apache.org/mod_fcgid/"
+SRC_URI="mirror://apache/httpd/mod_fcgid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ~ppc64 x86"
+IUSE=""
+
+APACHE2_MOD_CONF="2.2/20_${PN}"
+APACHE2_MOD_DEFINE="FCGID"
+
+DOCFILES="CHANGES-FCGID README-FCGID STATUS-FCGID"
+
+need_apache2
+
+src_compile () {
+ ./configure.apxs || die "apxs configure failed!"
+ make || die "make failed"
+ ln -sf modules/fcgid/.libs .libs || die "symlink creation failed"
+}