summaryrefslogtreecommitdiff
path: root/virtual/wireguard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /virtual/wireguard
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'virtual/wireguard')
-rw-r--r--virtual/wireguard/Manifest2
-rw-r--r--virtual/wireguard/metadata.xml12
-rw-r--r--virtual/wireguard/wireguard-1.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/virtual/wireguard/Manifest b/virtual/wireguard/Manifest
new file mode 100644
index 000000000000..9e812fbf8118
--- /dev/null
+++ b/virtual/wireguard/Manifest
@@ -0,0 +1,2 @@
+EBUILD wireguard-1.ebuild 921 BLAKE2B af41757e408eeed96f84285056e98e32996daeee7099f94b10bce6ae52b570f434ea2fb2a2fca1e2b1a2e8f15a0b32d9e03f39a6a49cbe8ca442bfd438fb4f8a SHA512 0c42159a3bab1443c7ae433d183910148cfa4e53349ab45dc71cdb565f816435f2a004ba5fc66ffa966348b44cb63f0f6e53e88bf09903d8e50e6fd0c0ef94db
+MISC metadata.xml 519 BLAKE2B 658024ee6de411e6c8248892b40c1049c574320ce42fa0950020465b04647045e59b459d2edae210ca75c5090b2867fa2ffedfde5e1fd3e004ee65b69e73b40a SHA512 fbff412fd91543d8ff53f2f28558e77e3ea7b569593e7a8d158e6056fce18627f1a5d3004f9ae67aface12ddf02a821938869ebab24fa850cf5f33fa9db6db4b
diff --git a/virtual/wireguard/metadata.xml b/virtual/wireguard/metadata.xml
new file mode 100644
index 000000000000..a2b169f1920c
--- /dev/null
+++ b/virtual/wireguard/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Compile the wg(8) tool and related helpers. You probably want this enabled.</flag>
+ <flag name="module">Compile the actual WireGuard kernel module. Most certainly you want this enabled, unless you're doing something strange.</flag>
+ </use>
+</pkgmetadata>
diff --git a/virtual/wireguard/wireguard-1.ebuild b/virtual/wireguard/wireguard-1.ebuild
new file mode 100644
index 000000000000..4fa639117c92
--- /dev/null
+++ b/virtual/wireguard/wireguard-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+module +tools"
+
+RDEPEND="
+ tools? ( net-vpn/wireguard-tools )
+ module? ( net-vpn/wireguard-modules )
+"
+
+pkg_postinst() {
+ ewarn
+ ewarn "This package, ${CATEGORY}/${PN}, has been deprecated, in favor of explicitly"
+ ewarn "merging the tools and the modules separately. You may accomplish this by"
+ ewarn "running:"
+ ewarn
+ ewarn " emerge -nO net-vpn/wireguard-tools net-vpn/wireguard-modules"
+ ewarn " emerge -C virtual/wireguard"
+ ewarn
+ ewarn "When Linux 5.6 comes out, net-vpn/wireguard-modules itself will be deprecated,"
+ ewarn "with its functionality having moved directly into Linux."
+ ewarn
+}