summaryrefslogtreecommitdiff
path: root/virtual/rust/rust-1.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
commitbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (patch)
treee255548891f2188ab2594eedde60d6f426ef24ed /virtual/rust/rust-1.70.0.ebuild
parentdef28ad1de5a6853465d7ff8f626cda6a774cd9e (diff)
gentoo auto-resync : 02:06:2023 - 09:28:30
Diffstat (limited to 'virtual/rust/rust-1.70.0.ebuild')
-rw-r--r--virtual/rust/rust-1.70.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.70.0.ebuild b/virtual/rust/rust-1.70.0.ebuild
new file mode 100644
index 000000000000..b2590567fddf
--- /dev/null
+++ b/virtual/rust/rust-1.70.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+#KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"