summaryrefslogtreecommitdiff
path: root/virtual/python-ipaddress
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/python-ipaddress
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/python-ipaddress')
-rw-r--r--virtual/python-ipaddress/Manifest3
-rw-r--r--virtual/python-ipaddress/metadata.xml8
-rw-r--r--virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild17
3 files changed, 28 insertions, 0 deletions
diff --git a/virtual/python-ipaddress/Manifest b/virtual/python-ipaddress/Manifest
new file mode 100644
index 000000000000..eb5548016e2a
--- /dev/null
+++ b/virtual/python-ipaddress/Manifest
@@ -0,0 +1,3 @@
+EBUILD python-ipaddress-1.0-r1.ebuild 533 SHA256 b8f5d6eb5edbc10fb817bc9e190df008ef5dfaa97a16b1b648659b4b252d85f7 SHA512 4ec30b687e542f4c47e383010becf615336d8592e21b7c0777b8ea7072622b047289d271cb1e0b3ac5fe292a45da578bb76f8a92eb0461c34809eb54f415480b WHIRLPOOL 3db1c1d0fa08b940a52c46b6fe9818b1b4135df525666fb661c907d28ce211789bed6510daece769920ab9143d273df783ecf90b548de3852ab2a9b5c3218a33
+MISC ChangeLog 1121 SHA256 c8f94c5bfe4d6be191da482ff4362a244efd838128ce750c8ad5e1b49bf01e09 SHA512 c32403030af2fa31d9b1fa9fec0e95c5df70429afa22b1a305b856406e175378493b5a9a795765576104c86c1376c16e090f9f6332a7454cb7f1477b1191604b WHIRLPOOL 4be54711f99b4af50c9ea877e456df365cd39582fbf55e9c6c03a6f0c0d798a87492535af7ba3b9a8eefbf122ae510abffff4f971466e9f426fb3e9f8e989f23
+MISC metadata.xml 240 SHA256 07a76e79a43ffd9aa15de0e4ae548ea85aa5bd165c4602630c3519e60f113ee6 SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59 WHIRLPOOL e3e059953c7c36bd942545f4e2a0e94ba938a17fe2bd04df81b137c185e64a213152c11918922563509e4767e601b41105f80c5983a87ee4d6be7704bcf7cf54
diff --git a/virtual/python-ipaddress/metadata.xml b/virtual/python-ipaddress/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/virtual/python-ipaddress/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
new file mode 100644
index 000000000000..0ae39494e51f
--- /dev/null
+++ b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python ipaddress module"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' \
+ python2_7 pypy)"