summaryrefslogtreecommitdiff
path: root/virtual/opencl/opencl-3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
commit28267a5e528b273fbd1b0f5f52ecaab4b03016ab (patch)
treef2c2ddc5cf19fcbc848cc9fe427df5abd8ac0339 /virtual/opencl/opencl-3-r2.ebuild
parente19b21c73e5feac42ade97baf3eeb45c58a2f234 (diff)
gentoo auto-resync : 24:07:2022 - 08:52:43
Diffstat (limited to 'virtual/opencl/opencl-3-r2.ebuild')
-rw-r--r--virtual/opencl/opencl-3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/virtual/opencl/opencl-3-r2.ebuild b/virtual/opencl/opencl-3-r2.ebuild
new file mode 100644
index 000000000000..56a9bf8353ab
--- /dev/null
+++ b/virtual/opencl/opencl-3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL API"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="|| ( dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}]
+ dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}] )"
+
+pkg_postinst() {
+ elog
+ elog "In order to take advantage of OpenCL you will need a runtime for your hardware."
+ elog "Currently included in Gentoo are:"
+ elog
+ elog " * open:"
+ elog " - dev-libs/intel-compute-runtime - integrated Intel GPUs from Broadwell onwards. 64-bit only;"
+ elog " - dev-libs/pocl - to run OpenCL programs on your CPU, if you do not have a supported GPU;"
+ elog " - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver. 64-bit only;"
+ elog " - media-libs/mesa[opencl] - some older AMD GPUs; see [1]. 32-bit support;"
+ elog
+ elog " * proprietary:"
+ elog " - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;"
+ elog " - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;"
+ elog " - x11-drivers/nvidia-drivers[uvm] - Nvidia GPUs; specific package versions"
+ elog " required for older devices [2]. 32-bit support."
+ elog
+ elog " [1] https://dri.freedesktop.org/wiki/GalliumCompute/"
+ elog " [2] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/"
+ elog
+}