summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
commitf5ef7f2371babf22c2c3fad17108692b09e4c98e (patch)
tree7f195ab30a74fa23e6dd24307d67d0890714d093 /sys-process
parent3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (diff)
gentoo auto-resync : 02:05:2024 - 00:00:17
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10144 -> 10142 bytes
-rw-r--r--sys-process/cronutils/Manifest3
-rw-r--r--sys-process/cronutils/cronutils-1.10.ebuild6
-rw-r--r--sys-process/cronutils/files/cronutils-1.10-musl-1.2.5.patch37
4 files changed, 44 insertions, 2 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 556d8909b31d..8cc5f01cd508 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/cronutils/Manifest b/sys-process/cronutils/Manifest
index 61cfe0b9984f..1b92bd595324 100644
--- a/sys-process/cronutils/Manifest
+++ b/sys-process/cronutils/Manifest
@@ -1,3 +1,4 @@
+AUX cronutils-1.10-musl-1.2.5.patch 1011 BLAKE2B 2c5e499410ace178cd4a75ded6c16bd2529e11c4a66252beb74763e61ad3a18ffb72de7eb1e23f174f74907ade51dba73232b280d50b180d79b9d33af1349a49 SHA512 267c6d08d0fc8ac141a6610ea669fa6a2c27fbdd1602dfd79b9b44cea9ba36512d0b09efd30a296edff4e2fe65b05d18fba65cbea40207036725b7bf8dea83b5
DIST cronutils-1.10.tar.gz 17098 BLAKE2B e450d9547355a6e6c447c533c69837b0e4a0c7f2100d1afe4088951ff988dea38029d3aac7433360ef3952d8ad9b1c0d90d6443546f7730e5bdd001612ed1ca7 SHA512 15f42054d86d7352d1454b3a18d959db3dc73d207fa3304708c002bfbcc86e630e97306ec84a26a904deb080428f5cc8c046aea55adbea2e69de2b4fab7538f4
-EBUILD cronutils-1.10.ebuild 577 BLAKE2B 0a54673ebdb95eea94740f1085337e5fa63de94f228537ab9831dffcbedbc706490a6b8204ba998e8f8cb07f128fc5372ae01d6df8c74ad9cceba6a7c09e1bde SHA512 13fea4cfcfb644cb1b512625d46e6dd4d49fa411a830f9d3782c7876f40bce0e267da93c3df2bb4f424994af3269aa7de9afbed7e92c8cb4ca4400f051e9c1f8
+EBUILD cronutils-1.10.ebuild 627 BLAKE2B 3c222e67fd2fc2329720d49fd7c30b88a72ff6608b03876ac948ac03483cc72b0abac8d454ca3d1561cc4e60f55484bda2708a2ca2c347576b1f3bc6376db633 SHA512 31092b20eecfe861fe3a1f3452be114f862a9fc8c4d2cf466d25c092bf7f9bb69f38e99b19503065d8567174bc99146d6709318beee7d7560b8eeda3759d9043
MISC metadata.xml 510 BLAKE2B 07ae44cef47f71594f43af7f8d0f7669937a4e36ca7182cb0ae5d0ca16740b3eb04f19009f6baa2f4a39e1cfc01ea80d185ab745cf32041ab7ddc8d2a067d1e9 SHA512 5c6b6411bca47f2540b286334d7e0336c086e0a877a2ae82146e8b4247c69daaaa8b44729328d3b596c3823c801c6acc61974705c5e0536eca3d15ceb7809413
diff --git a/sys-process/cronutils/cronutils-1.10.ebuild b/sys-process/cronutils/cronutils-1.10.ebuild
index 852bd502e451..04037ab1c5ac 100644
--- a/sys-process/cronutils/cronutils-1.10.ebuild
+++ b/sys-process/cronutils/cronutils-1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,6 +14,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
+PATCHES=(
+ "${FILESDIR}/${P}-musl-1.2.5.patch"
+)
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
}
diff --git a/sys-process/cronutils/files/cronutils-1.10-musl-1.2.5.patch b/sys-process/cronutils/files/cronutils-1.10-musl-1.2.5.patch
new file mode 100644
index 000000000000..a332dcb5a432
--- /dev/null
+++ b/sys-process/cronutils/files/cronutils-1.10-musl-1.2.5.patch
@@ -0,0 +1,37 @@
+From cbab73af5a3c218aabd16e3733c77d2b1c541564 Mon Sep 17 00:00:00 2001
+From: Paul Meyer <49727155+katexochen@users.noreply.github.com>
+Date: Wed, 31 Jan 2024 20:12:01 +0100
+Subject: [PATCH] add missing libgen include
+
+Without including libgen.h, build will fail on darwin as basename isn't declared.
+
+Signed-off-by: Paul Meyer <49727155+katexochen@users.noreply.github.com>
+---
+ runalarm.c | 1 +
+ runlock.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/runalarm.c b/runalarm.c
+index fb8617a..95a40ac 100644
+--- a/runalarm.c
++++ b/runalarm.c
+@@ -17,6 +17,7 @@ limitations under the License.
+ #define _GNU_SOURCE /* basename */
+
+ #include <errno.h>
++#include <libgen.h>
+ #include <signal.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+diff --git a/runlock.c b/runlock.c
+index 0e446b0..75ac08f 100644
+--- a/runlock.c
++++ b/runlock.c
+@@ -18,6 +18,7 @@ limitations under the License.
+
+ #include <errno.h>
+ #include <fcntl.h>
++#include <libgen.h>
+ #include <limits.h>
+ #include <signal.h>
+ #include <stdio.h>