summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 21:59:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 21:59:10 +0000
commit94f15e80a2d1bf7754cad4b53208be9c319ea7d5 (patch)
treeb7b87202adaa45edbdde23c9635d88ccefd83b68 /sys-process
parentba7a238ca9c95cb73dc1040bfe42d78dd6970126 (diff)
gentoo auto-resync : 08:02:2024 - 21:59:09
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10140 -> 10138 bytes
-rw-r--r--sys-process/iotop-c/Manifest2
-rw-r--r--sys-process/iotop-c/iotop-c-1.26.ebuild43
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 03cba3e6608d..c5e098a9c35a 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index 338c602068ac..805684da27f5 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1,3 +1,5 @@
DIST iotop-c-1.25.tar.gz 139627 BLAKE2B a159ae3a4e5be87776d7111e38685e2f83fd907b82a09ec9b4a7d5c778d3a2c5a6e544452c126ff76b0fca2a4038cec1415a654156186dfb2534649a295eb65c SHA512 b696d0478e08373a923475493d67912959d78369f086179590482fb8e6ec349d0c8f5e6118e0aa353d2827b8d83f14bf334cf50cf55f6859bd8d9317543031e0
+DIST iotop-c-1.26.tar.gz 139536 BLAKE2B 90bb3db7dd3b05604fa5368a881434eac06509921447fd53bda7e7291e2c823f82f9015f0c16c516dcfa7c8ee6198466b8634eaf1b111b4f911645b97fc2634f SHA512 47246bc025c396bcd7569bd19d52079701e3b86ab239ac3db1d1386f358f6e95a63d7bad8c1d0552fb61315a9db282967c65e110703863ae71fa6260b775942b
EBUILD iotop-c-1.25.ebuild 879 BLAKE2B ad5d6b591f666f8d2fd3f287df26b0f1f311e4d125fe9e49128a4a50ca2b9e4c593a3e57233dcc2ceaca4672c939ca59b79b2b883fc0bd9f2a744b51c4e4d146 SHA512 85f9371c073cf5007a2f536dade0e1886b9ef3938332d7e315ad2d663d9c2a2f4f4a601a117aaa1db2b2577b9786bc9c23e34e7aabab3005dc98a3daac401203
+EBUILD iotop-c-1.26.ebuild 883 BLAKE2B 22a020c59c18db6a224d9bcc98a0b0df66cb31015e378f9c9a36a451c00ef7b0e92944f3498791bde4a07e53f4504e16b3fbe642c69f9199f5cddc3da0b9d5e9 SHA512 964fd6c916e45e6b527d69902fc19ccbfba3c1f1fb67e2225196da387c4390eeffa8f8db75bb33a9d171e061213ebb263f0787e1fba67bdd97a4f68ce06d41d9
MISC metadata.xml 1377 BLAKE2B 1b0e762f6677fd063044d1ad811fda5c95f64b36a51310dd3d9d0e652d9d671fe255a9cfa312d299369b19d4206723aa5010994ff6e20bf1b67be92432cb4350 SHA512 c5eee7ec3b5711666029d57eb84319e3f89373d7f73d067d1b990ecfcc6d98625966fb781ea3a47894ea078cfca40fc5f03a8d70dd83f7c93b8a77a6e14d2de0
diff --git a/sys-process/iotop-c/iotop-c-1.26.ebuild b/sys-process/iotop-c/iotop-c-1.26.ebuild
new file mode 100644
index 000000000000..8206a88232a6
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.26.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ !sys-process/iotop
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}