summaryrefslogtreecommitdiff
path: root/sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 07:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 07:39:06 +0100
commit4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (patch)
treeac0800b987f671677c408554735a832a6924b9a6 /sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild
parentae5005f56ad29d19861ad8a8acb541cf0e99c8d9 (diff)
gentoo auto-resync : 14:07:2022 - 07:39:06
Diffstat (limited to 'sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild')
-rw-r--r--sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild b/sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild
new file mode 100644
index 000000000000..cd90995efde0
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20220705-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson systemd
+
+MY_COMMIT="f10f38e3adcaf6175e6c4c1846cad72ae9ab2cf2"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://codeberg.org/pf-kernel/uksmd"
+SRC_URI="https://codeberg.org/pf-kernel/uksmd/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/libcap-ng
+ sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/uksmd"
+
+PATCHES=( "${FILESDIR}"/uksmd-0-remove-systemd-dep.patch )
+
+src_install() {
+ meson_src_install
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit uksmd.service
+}