summaryrefslogtreecommitdiff
path: root/sys-process/tini/tini-0.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/tini/tini-0.13.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/tini/tini-0.13.2.ebuild')
-rw-r--r--sys-process/tini/tini-0.13.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/tini/tini-0.13.2.ebuild b/sys-process/tini/tini-0.13.2.ebuild
new file mode 100644
index 000000000000..201e3b75b34f
--- /dev/null
+++ b/sys-process/tini/tini-0.13.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="A tiny but valid init for containers"
+HOMEPAGE="https://github.com/krallin/tini"
+SRC_URI="https://github.com/krallin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~x86"
+IUSE="+args +static"
+
+src_prepare() {
+ default
+ # Do not strip binary
+ sed -i -e 's/-Wl,-s")$/")/' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use args || mycmakeargs+=(-DMINIMAL=ON)
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ append-cflags -DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use static; then
+ mv "${ED%/}"/usr/bin/{${PN}-static,${PN}} || die
+ else
+ rm "${ED%/}"/usr/bin/${PN}-static || die
+ fi
+}