summaryrefslogtreecommitdiff
path: root/sys-process/systemd-cron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-process/systemd-cron
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-process/systemd-cron')
-rw-r--r--sys-process/systemd-cron/Manifest4
-rw-r--r--sys-process/systemd-cron/metadata.xml1
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.15.ebuild86
3 files changed, 90 insertions, 1 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index db7e3c76fd8a..0991e553c6f2 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,3 +1,5 @@
DIST systemd-cron-1.5.14.tar.gz 31634 BLAKE2B 59394128145dbd04a2b1bb10a6ac8821a97a465e3c0d43f3ca8fdfe60db273352d46b1200c966adaf772272835269c5c553b040cb0e0340ec56340181c9b7245 SHA512 772a4f8181a0f8039a8138fdc43bfe0f2bd89222fe19fa971727be265036f86435334d6230e116440f6969425fc6d59dc26e9cf230c00d030ea5d62ba351713c
+DIST systemd-cron-1.5.15.tar.gz 32334 BLAKE2B 7802f442a4ef3d4789f4ea0d534d5c52519313873fa53a43f036e9ffeb36eeec420ff9a5a952b4b7f2f57bfcaf733432e067483dd4984be60c12853ae83a1f9c SHA512 b1c79275b88cba63b69112085d93ba52ba4a2966bdcdc722bdcd69c0270fd02bab96b8045d9ab79781b8f54a79a2ece942d97a6faa7d0cb50c31a13364b7179d
EBUILD systemd-cron-1.5.14.ebuild 2055 BLAKE2B c641214b325e3ca317cfc632359a561bd64c7a39a60239c1cf01d8f1c1b91485fe009b497d7eb435f31d415e813846296804f542b6fe42e3a8a7fd94305541f0 SHA512 16ab5ad7b09d19a608be8b3c57afdaef727027664e2460fbe13efd55a987ff7c21bf9a07b51425fb8b242d03cbbce2c50b6ec2bcf92851c4cd65829357d0bab0
-MISC metadata.xml 696 BLAKE2B 9487789802e271bb95d8c44c5f279f8c850b928e8a2547ce7a1b47e2db3aef119265c0d8e36b8dfba3c62e3b7d4ccc040ba7983dec6c6328fc11e10e7ffd4ecc SHA512 54efb7e34c7e83c0ac3e964e300705b3b33c2dd93dc711c6e71b9d93d83a627f0318ce757b01feb6d6e1edd228f94ab180394617803dcc23c5e73aece9c9f7c1
+EBUILD systemd-cron-1.5.15.ebuild 2425 BLAKE2B d8c67eb4949f3590a995565e1f0ff641422dad1fb2fd8e98185fb2e046460ab7ae2abc7f480b7e7dea851122303f2a85035ba1ad7e1b28267566f0a72e50cddf SHA512 0f879bdce6278825046ccb86d9c36071f6efb8f9c8dcf5ebe2d24242914e481604cc42abfce744022f7dcff672f0b883dcd052d0247032c0a6b2e18d35764a12
+MISC metadata.xml 800 BLAKE2B f169b22b17cce214f505ab977f30f53298af2b08dc1a453221f71d70708fd15c08a27303a6ebdf565cbedeba59deee68d112ed87b5bbdc2891a60471412c560e SHA512 2768df83a79446843038fbbbc7342de9206081fd8f8f26cdb92ca202c3ca35a98727a9bf220f8744f204a9e6974ac0bcd515f6a52e411a26767eb29a9a7f2fde
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
index a2e9865130b7..6386b9371135 100644
--- a/sys-process/systemd-cron/metadata.xml
+++ b/sys-process/systemd-cron/metadata.xml
@@ -8,6 +8,7 @@
<flag name="cron-boot">Include support for the boot timer.</flag>
<flag name="etc-crontab-systemd">Use dedicated /etc/crontab-systemd instead of parsing /etc/crontab</flag>
<flag name="minutely">Support /etc/cron.minutely</flag>
+ <flag name="runparts">Use traditional run-parts instead of creating jobs for each cron.* entry</flag>
<flag name="yearly">Support /etc/cron.yearly</flag>
<flag name="setgid">Compile setgid C helper for crontab. Needs GCC or Clang.</flag>
</use>
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild
new file mode 100644
index 000000000000..d26a7c23352f
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-apps/systemd-217
+ sys-apps/debianutils
+ !sys-process/cronie[anacron]
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase"
+
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db dev-python/pyflakes )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -e 's/pyflakes3/pyflakes/' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ --generatordir="$(systemd_get_systemgeneratordir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable runparts) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}
+
+pkg_postinst() {
+ elog "This package now supports USE=runparts which is enabled by default."
+ elog "This enables the traditional run-parts behavior."
+ elog "If you disable this flag you will get the new behavior of having"
+ elog "multiple jobs for each cron.* entry run in parallel with"
+ elog "separate services/logs/etc."
+}