summaryrefslogtreecommitdiff
path: root/sys-process/procps/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
commite5206efa6e88d32e3819685adee35c49124ccf0e (patch)
treeeb8101c8b97f1aa253537d4ea141dc5bf9c9902b /sys-process/procps/files
parent15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (diff)
gentoo auto-resync : 02:09:2023 - 16:16:36
Diffstat (limited to 'sys-process/procps/files')
-rw-r--r--sys-process/procps/files/procps-4.0.4-fix-systemd-linkage.patch27
-rw-r--r--sys-process/procps/files/procps-4.0.4-fix-tests-multilib.patch52
-rw-r--r--sys-process/procps/files/procps-4.0.4-sysctl-manpage.patch33
-rw-r--r--sys-process/procps/files/procps-4.0.4-xfail-pmap-test.patch25
4 files changed, 137 insertions, 0 deletions
diff --git a/sys-process/procps/files/procps-4.0.4-fix-systemd-linkage.patch b/sys-process/procps/files/procps-4.0.4-fix-systemd-linkage.patch
new file mode 100644
index 000000000000..32f4d6da6dc6
--- /dev/null
+++ b/sys-process/procps/files/procps-4.0.4-fix-systemd-linkage.patch
@@ -0,0 +1,27 @@
+https://gitlab.com/procps-ng/procps/-/commit/ca004d4657d5e8b468a4552ede429be53193a3a9
+
+From ca004d4657d5e8b468a4552ede429be53193a3a9 Mon Sep 17 00:00:00 2001
+From: Craig Small <csmall@dropbear.xyz>
+Date: Thu, 31 Aug 2023 22:24:23 +1000
+Subject: [PATCH] build-sys: Add systemd/elogind to w
+
+Depending on the compiler flags, w needs to be explictly linked
+to libsystemd or elogind even though libproc2 is linked to it.
+
+Signed-off-by: Craig Small <csmall@dropbear.xyz>
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -149,6 +149,13 @@ endif
+
+ dist_man_MANS += man/w.1
+ src_w_SOURCES = src/w.c local/fileutils.c
++src_w_LDADD = $(LDADD)
++if WITH_SYSTEMD
++src_w_LDADD += @SYSTEMD_LIBS@
++endif
++if WITH_ELOGIND
++src_w_LDADD += @ELOGIND_LIBS@
++endif
+ else
+ EXTRA_DIST += man/w.1
+ endif
diff --git a/sys-process/procps/files/procps-4.0.4-fix-tests-multilib.patch b/sys-process/procps/files/procps-4.0.4-fix-tests-multilib.patch
new file mode 100644
index 000000000000..ed52af8582b9
--- /dev/null
+++ b/sys-process/procps/files/procps-4.0.4-fix-tests-multilib.patch
@@ -0,0 +1,52 @@
+https://gitlab.com/procps-ng/procps/-/merge_requests/205
+
+From 4b6b91b393c0f5d3ec26910785cb3e3a463fcb57 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 2 Sep 2023 10:46:38 +0100
+Subject: [PATCH] testsuite: skip tests where relevant binaries aren't built
+
+* With --without-ncurses, slabtop isn't built.
+* With --disable-w, w isn't built.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -14,16 +14,23 @@ if LINUX
+ # 3d807ae853b8b4264da156065b34f1447658a8ba
+ DEJATOOL += \
+ pmap
++
+ if !CYGWIN
+-DEJATOOL += \
+- slabtop \
+- sysctl
++if WITH_NCURSES
++DEJATOOL += slabtop
++endif
++
++DEJATOOL += sysctl
+ endif
+
+ if BUILD_KILL
+ DEJATOOL += kill
+ endif
+
++if BUILD_W
++DEJATOOL += w
++endif
++
+ DEJATOOL += \
+ free \
+ lib \
+@@ -31,10 +38,8 @@ DEJATOOL += \
+ pkill \
+ ps \
+ pwdx \
+- slabtop \
+ uptime \
+- vmstat \
+- w
++ vmstat
+ endif
+
+ EXTRA_DIST = \
diff --git a/sys-process/procps/files/procps-4.0.4-sysctl-manpage.patch b/sys-process/procps/files/procps-4.0.4-sysctl-manpage.patch
new file mode 100644
index 000000000000..3582f7e79306
--- /dev/null
+++ b/sys-process/procps/files/procps-4.0.4-sysctl-manpage.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/565304
+--- a/man/sysctl.8
++++ b/man/sysctl.8
+@@ -141,21 +141,21 @@ replaced (by having a new configuration file with the same name in a
+ directory of higher priority) or partially replaced (by having a configuration
+ file that is ordered later).
+ .SH EXAMPLES
+-/sbin/sysctl \-a
++/usr/bin/sysctl \-a
+ .br
+-/sbin/sysctl \-n kernel.hostname
++/usr/bin/sysctl \-n kernel.hostname
+ .br
+-/sbin/sysctl \-w kernel.domainname="example.com"
++/usr/bin/sysctl \-w kernel.domainname="example.com"
+ .br
+-/sbin/sysctl \-p/etc/sysctl.conf
++/usr/bin/sysctl \-p/etc/sysctl.conf
+ .br
+-/sbin/sysctl \-a \-\-pattern forward
++/usr/bin/sysctl \-a \-\-pattern forward
+ .br
+-/sbin/sysctl \-a \-\-pattern forward$
++/usr/bin/sysctl \-a \-\-pattern forward$
+ .br
+-/sbin/sysctl \-a \-\-pattern 'net.ipv4.conf.(eth|wlan)0.arp'
++/usr/bin/sysctl \-a \-\-pattern 'net.ipv4.conf.(eth|wlan)0.arp'
+ .br
+-/sbin/sysctl \-\-pattern '\[char94]net.ipv6' \-\-system
++/usr/bin/sysctl \-\-pattern '\[char94]net.ipv6' \-\-system
+ .SH DEPRECATED PARAMETERS
+ The
+ .B base_reachable_time
diff --git a/sys-process/procps/files/procps-4.0.4-xfail-pmap-test.patch b/sys-process/procps/files/procps-4.0.4-xfail-pmap-test.patch
new file mode 100644
index 000000000000..037fe657f4ea
--- /dev/null
+++ b/sys-process/procps/files/procps-4.0.4-xfail-pmap-test.patch
@@ -0,0 +1,25 @@
+--- a/testsuite/pmap.test/pmap.exp
++++ b/testsuite/pmap.test/pmap.exp
+@@ -87,13 +87,15 @@ proc expect_twice_total { test } {
+ }
+ }
+
+-set test "pmap X pid pid has same total"
+-spawn $pmap -X $mypid $mypid
+-expect_twice_total "$test"
+-
+-set test "pmap XX pid pid has same total"
+-spawn $pmap -XX $mypid $mypid
+-expect_twice_total "$test"
++# Fails in gentoo sandbox, needs investigation
++#set test "pmap X pid pid has same total"
++#spawn $pmap -X $mypid $mypid
++#expect_twice_total "$test"
++
++# Fails in gentoo sandbox, needs investigation
++#set test "pmap XX pid pid has same total"
++#spawn $pmap -XX $mypid $mypid
++#expect_twice_total "$test"
+
+ set test "pmap finding shm"
+ make_testshm_proc