summaryrefslogtreecommitdiff
path: root/sys-process/procenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
commit9b6120d8af003bb775da6737dfe42f8f580f59f6 (patch)
tree965a7890c4893d608fd8d3ce04030376ab565a45 /sys-process/procenv
parent80765b090d10ae3f68b00e3befe5859f7212e536 (diff)
gentoo auto-resync : 15:07:2023 - 10:39:50
Diffstat (limited to 'sys-process/procenv')
-rw-r--r--sys-process/procenv/Manifest2
-rw-r--r--sys-process/procenv/files/procenv-0.51-musl-sysmacros.patch53
-rw-r--r--sys-process/procenv/procenv-0.51-r1.ebuild29
3 files changed, 84 insertions, 0 deletions
diff --git a/sys-process/procenv/Manifest b/sys-process/procenv/Manifest
index 8a156f75c8f1..d28c1e292ee8 100644
--- a/sys-process/procenv/Manifest
+++ b/sys-process/procenv/Manifest
@@ -1,4 +1,6 @@
AUX procenv-0.45-flags.patch 282 BLAKE2B a3caa11121631a2676146ef7195e154743d99c970a4b5c2a8b5e5b90716c30b56fa830ae06e7f580e4854aefde64000a0d803995d2a23cc89e52b42a35e024ea SHA512 ef90b8659f63ffaa114244e9b02b345c721e26bdbd5181b6daf45eff9671c442cc94b853d3e66fef16b20614515d4ae0885662c8875b529aa552ccd345c1e41b
+AUX procenv-0.51-musl-sysmacros.patch 1296 BLAKE2B 116c352f6c8d76e0c6815d17f284b4e1dacce1b53afb1b8577454e5cb47d2e684e036a2b2bd32db6898e74d42cd698e596329f7468b8cad6929e00916f263cae SHA512 d41a7bae019035d95245397c2c13d65f15ee2cda4c5fd2bb12a887c53ae1ca8186adfe6f9f95e5bfc55dc3a378dd46d2ff16e2c085d6886a0fe71e2bd5943754
DIST procenv-0.51.tar.gz 245663 BLAKE2B 1e7a0b9fddbe0c4f0aaf895ae1174f69c84d6b043794b5cd23f678dc5c762d892e49ce9b91c78c0fc3bd4cf4064e94c1c43758b4cdd596d6d289a929b3855043 SHA512 0f0b0fb4aceb4c6aaa4f2f4f8e139dfbcecbed2101ac4c44e4b1f85420fbf15967b9ebf8c3d2868260afc2957919f15a981ae49f0cf91c9f2c7ea05c96dc36fb
+EBUILD procenv-0.51-r1.ebuild 631 BLAKE2B 1a59aa41f7496ec06b56b3a8135f1786650f35b81d8c51aa69f095bf040aeed83d53dadf0b6b487520bdf074762611e19cdbcd834bf8f73bf579e1b7781f644c SHA512 cc031e8a44457e42dbeb6acb0ab0b1a3a3cd706502396b45a39e098824d49e550957af88b7efc6aebad38207cac0c10f7907a1f7b84340e16ed90e8d0556601b
EBUILD procenv-0.51.ebuild 593 BLAKE2B 24ee4dfd0adcd6a1250131a44a226ba5302a92cff31f4f66745955459452b3adb044653aed7277265e31ab9cbf6bf9dd37bba75e54e9f11230092e0771bed96b SHA512 1d34a4b839eaa15b0dd476cbbb2c0ef8c48f6dd40cebf86cf9e9ad6b99c3aca32bc5590983dc2d69f986866bea17b98cb5ec6eeedeafbd2006853bcf1d45483b
MISC metadata.xml 302 BLAKE2B 7b07a2a12866e21076292bea1e1ddf86aa6397d8ab768cf72591ddad1ad2436ddd447db496d4d1d594368ae4ecd7f5c33f763de57a3f1d3ba3e001c89c86fd9f SHA512 9ae13eeda3bbd48141d9e4e22ffced6d71e65516e0e23126f6b9982c30f06d7eaa272bd42d34a4b153a97437294ac93c591a58780f7aab3f7caef732bafeaf64
diff --git a/sys-process/procenv/files/procenv-0.51-musl-sysmacros.patch b/sys-process/procenv/files/procenv-0.51-musl-sysmacros.patch
new file mode 100644
index 000000000000..cd93a1d359ac
--- /dev/null
+++ b/sys-process/procenv/files/procenv-0.51-musl-sysmacros.patch
@@ -0,0 +1,53 @@
+https://github.com/jamesodhunt/procenv/pull/27
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Mon, 5 Jun 2023 14:10:48 +0000
+Subject: [PATCH] Fix build on musl libc
+
+On util.c the guard around #include sys/sysmacros.h prevents musl libc
+from including the file, even though musl provides the header file, thus
+failing with errors such as "call to undeclared function makedev".
+
+In procenv.c although the function makedev is used but the file
+sysmacros.h was never included, thus resulting in similar "call to
+undeclared function makedev" error hence moving inclusion sysmacros.h to
+source file from header file.
+
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/src/procenv.c
++++ b/src/procenv.c
+@@ -27,6 +27,8 @@
+ */
+
+ #include <procenv.h>
++/* major(3) / minor(3) */
++#include <sys/sysmacros.h>
+
+ /**
+ * doc:
+--- a/src/procenv.h
++++ b/src/procenv.h
+@@ -103,9 +103,6 @@
+ #define PACKAGE_STRING PACKAGE_NAME
+ #endif
+
+-/* major(3) / minor(3) */
+-#include <sys/sysmacros.h>
+-
+ #endif /* PROCENV_PLATFORM_ANDROID */
+
+ /*********************************************************************/
+--- a/src/util.c
++++ b/src/util.c
+@@ -17,9 +17,7 @@
+ */
+
+ #include "util.h"
+-#if __GLIBC__
+ #include <sys/sysmacros.h>
+-#endif
+
+ // FIXME
+ extern struct procenv_user user;
+--
+2.40.1
+
diff --git a/sys-process/procenv/procenv-0.51-r1.ebuild b/sys-process/procenv/procenv-0.51-r1.ebuild
new file mode 100644
index 000000000000..d59d5338b0af
--- /dev/null
+++ b/sys-process/procenv/procenv-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ "${FILESDIR}"/${PN}-0.51-musl-sysmacros.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}