summaryrefslogtreecommitdiff
path: root/sys-process/parallel/parallel-20221022.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
commitcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (patch)
treeba764e9926b855c14e54b63112216041a4ab7e51 /sys-process/parallel/parallel-20221022.ebuild
parent1bb02f2ca2710df2358072c9a036ae83d2ece88c (diff)
gentoo auto-resync : 25:10:2022 - 09:53:29
Diffstat (limited to 'sys-process/parallel/parallel-20221022.ebuild')
-rw-r--r--sys-process/parallel/parallel-20221022.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/parallel/parallel-20221022.ebuild b/sys-process/parallel/parallel-20221022.ebuild
new file mode 100644
index 000000000000..5f26fa471823
--- /dev/null
+++ b/sys-process/parallel/parallel-20221022.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}