summaryrefslogtreecommitdiff
path: root/sys-process/numad/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/numad/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/numad/files')
-rw-r--r--sys-process/numad/files/0001-Fix-man-page-directory-creation.patch26
-rw-r--r--sys-process/numad/files/numad-0.5-ldlibs.patch34
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch b/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch
new file mode 100644
index 000000000000..0b8a1d7c27ff
--- /dev/null
+++ b/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch
@@ -0,0 +1,26 @@
+From 276611ad637334a6e3ea464540b204318f832ba8 Mon Sep 17 00:00:00 2001
+From: Doug Goldstein <cardoe@cardoe.com>
+Date: Wed, 13 Jun 2012 17:49:52 -0500
+Subject: [PATCH] Fix man page directory creation
+
+When building inside of a buildroot, the path for the man page might not
+exist so create it before we attempt to install a file into it.
+---
+ Makefile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d9adca9..32ad480 100755
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,7 @@ RANLIB ?= ranlib
+
+ install: numad
+ mkdir -p ${prefix}/bin
++ mkdir -p ${prefix}/share/man/man8
+ install -m 0755 numad ${prefix}/bin
+ install -m 0644 numad.8 ${prefix}/share/man/man8
+
+--
+1.7.3.4
+
diff --git a/sys-process/numad/files/numad-0.5-ldlibs.patch b/sys-process/numad/files/numad-0.5-ldlibs.patch
new file mode 100644
index 000000000000..d124e32e9ee4
--- /dev/null
+++ b/sys-process/numad/files/numad-0.5-ldlibs.patch
@@ -0,0 +1,34 @@
+From 9eb3cc5c51d846c8c8b750a4eb55545d7b5fea6c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 23 Apr 2014 15:41:26 -0400
+Subject: [PATCH] use LDLIBS for linker flags
+
+When you put -lfoo into the dependency line of make, it forces it to
+search /lib and /usr/lib for files to link against. This can cause
+problems when trying to cross-compile or build for different ABIs.
+Use the standard LDLIBS variable instead.
+
+URL: https://bugs.gentoo.org/505760
+Reported-by: Georgi Georgiev <chutzimir@gmail.com>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f3838b4..f2e9a6e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -31,7 +31,8 @@ docdir := ${prefix}/share/doc
+
+ all: numad
+
+-numad: numad.o -lpthread
++LDLIBS := -lpthread
++numad: numad.o
+
+ AR ?= ar
+ RANLIB ?= ranlib
+--
+1.9.2
+