summaryrefslogtreecommitdiff
path: root/sys-process/numactl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /sys-process/numactl/files
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'sys-process/numactl/files')
-rw-r--r--sys-process/numactl/files/numactl-2.0.8-static_libs.patch86
-rw-r--r--sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch12
-rw-r--r--sys-process/numactl/files/numactl-2.0.9-testsuite_path.patch14
3 files changed, 0 insertions, 112 deletions
diff --git a/sys-process/numactl/files/numactl-2.0.8-static_libs.patch b/sys-process/numactl/files/numactl-2.0.8-static_libs.patch
deleted file mode 100644
index efb84ff6240a..000000000000
--- a/sys-process/numactl/files/numactl-2.0.8-static_libs.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-Build static libs without -fPIC and only if BUILD_STATIC=yes
-
-https://bugs.gentoo.org/379849
-
-Patch written by Kacper Kowalik <xarthisius@gentoo.org>
---- a/Makefile
-+++ b/Makefile
-@@ -7,6 +7,8 @@
- # for compatibility with old releases
- CFLAGS += ${OPT_CFLAGS}
- override CFLAGS += -I.
-+# build static libraries by default
-+BUILD_STATIC ?= yes
-
- # find out if compiler supports __thread
- THREAD_SUPPORT := $(shell if $(CC) $(CFLAGS) threadtest.c -o threadtest \
-@@ -24,6 +26,7 @@
-
- CLEANFILES := numactl.o libnuma.o numactl numademo numademo.o distance.o \
- memhog libnuma.so libnuma.so.1 numamon numamon.o syscall.o bitops.o \
-+ distance.pic.o libnuma.pic.o syscall.pic.o \
- memhog.o util.o stream_main.o stream_lib.o shm.o stream clearcache.o \
- test/pagesize test/tshared test/mynode.o test/tshared.o mt.o empty.o empty.c \
- test/mynode test/ftok test/prefered test/randmap \
-@@ -40,11 +43,16 @@
- libdir := ${prefix}/$(shell ./getlibdir)
- docdir := ${prefix}/share/doc
-
-+NUMA_LIBS = libnuma.so
-+ifeq ($(BUILD_STATIC),yes)
-+NUMA_LIBS+= libnuma.a
-+endif
-+
- all: numactl migratepages migspeed libnuma.so numademo numamon memhog \
- test/tshared stream test/mynode test/pagesize test/ftok test/prefered \
- test/randmap test/nodemap test/distance test/tbitmap test/move_pages \
- test/mbind_mig_pages test/migrate_pages test/realloc_test libnuma.a \
-- test/node-parse numastat
-+ test/node-parse numastat ${NUMA_LIBS}
-
- numactl: numactl.o util.o shm.o bitops.o libnuma.so
-
-@@ -81,13 +89,14 @@
-
- libnuma.so.1: versions.ldscript
-
--libnuma.so.1: libnuma.o syscall.o distance.o affinity.o sysfs.o rtnetlink.o
-+libnuma.so.1: libnuma.pic.o syscall.pic.o distance.pic.o affinity.pic.o sysfs.pic.o rtnetlink.pic.o
- ${CC} ${LDFLAGS} -shared -Wl,-soname=libnuma.so.1 -Wl,--version-script,versions.ldscript -Wl,-init,numa_init -Wl,-fini,numa_fini -o libnuma.so.1 $(filter-out versions.ldscript,$^)
-
- libnuma.so: libnuma.so.1
- ln -sf libnuma.so.1 libnuma.so
-
--libnuma.o : CFLAGS += -fPIC
-+%.pic.o: %.c
-+ ${CC} -fPIC ${CPPFLAGS} ${CFLAGS} -c $< -o $@
-
- AR ?= ar
- RANLIB ?= ranlib
-@@ -95,16 +104,6 @@
- $(AR) rc $@ $^
- $(RANLIB) $@
-
--distance.o : CFLAGS += -fPIC
--
--syscall.o : CFLAGS += -fPIC
--
--affinity.o : CFLAGS += -fPIC
--
--sysfs.o : CFLAGS += -fPIC
--
--rtnetlink.o : CFLAGS += -fPIC
--
- test/tshared: test/tshared.o libnuma.so
-
- test/mynode: test/mynode.o libnuma.so
-@@ -143,7 +148,9 @@
- mkdir -p ${libdir}
- install -m 0755 libnuma.so.1 ${libdir}
- cd ${libdir} ; ln -sf libnuma.so.1 libnuma.so
-+ifeq ($(BUILD_STATIC),yes)
- install -m 0644 libnuma.a ${libdir}
-+endif
- mkdir -p ${prefix}/include
- install -m 0644 numa.h numaif.h numacompat1.h ${prefix}/include
- install -m 0755 numastat ${prefix}/bin
diff --git a/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch b/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch
deleted file mode 100644
index 27a97fdf2509..000000000000
--- a/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Tests fail with /bin/dash
-
-Singned-off-by: Lars Wendler <polynomial-c@gentoo.org>
-
---- numactl-2.0.9/test/printcpu
-+++ numactl-2.0.9/test/printcpu
-@@ -1,4 +1,4 @@
--#!/bin/sh
-+#!/bin/bash
- #print cpu it is running on
- declare -a arr
- arr=( $(< /proc/self/stat) )
diff --git a/sys-process/numactl/files/numactl-2.0.9-testsuite_path.patch b/sys-process/numactl/files/numactl-2.0.9-testsuite_path.patch
deleted file mode 100644
index 018fc6dbcd18..000000000000
--- a/sys-process/numactl/files/numactl-2.0.9-testsuite_path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur numactl-2.0.10-orig/test/bind_range numactl-2.0.10/test/bind_range
---- numactl-2.0.10-orig/test/bind_range 2015-05-03 22:23:31.095600314 -0400
-+++ numactl-2.0.10/test/bind_range 2015-05-03 22:25:29.107592557 -0400
-@@ -93,8 +93,8 @@
-
- HIGHESTCPU=$(grep 'processor' /proc/cpuinfo | tail -n1 | cut -f2 -d':')
- HIGHESTCPU=$(echo $HIGHESTCPU | cut -f2 -d' ')
--HIGHESTNODE=$(numactl -H | grep -e 'node [0-9]* cpus' | tail -n1 | cut -f2 -d' ')
--LOWESTNODE=$(numactl -H | grep -e 'node [0-9]* cpus' | head -n1 | cut -f2 -d' ')
-+HIGHESTNODE=$(../numactl -H | grep -e 'node [0-9]* cpus' | tail -n1 | cut -f2 -d' ')
-+LOWESTNODE=$(../numactl -H | grep -e 'node [0-9]* cpus' | head -n1 | cut -f2 -d' ')
-
- get_mask
-