summaryrefslogtreecommitdiff
path: root/sys-process/gnome-usage/gnome-usage-45.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /sys-process/gnome-usage/gnome-usage-45.0.ebuild
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'sys-process/gnome-usage/gnome-usage-45.0.ebuild')
-rw-r--r--sys-process/gnome-usage/gnome-usage-45.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/gnome-usage/gnome-usage-45.0.ebuild b/sys-process/gnome-usage/gnome-usage-45.0.ebuild
new file mode 100644
index 000000000000..a7ae47a009a8
--- /dev/null
+++ b/sys-process/gnome-usage/gnome-usage-45.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A nice way to view information about use of system resources"
+HOMEPAGE="https://wiki.gnome.org/Apps/Usage"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/libgee-0.8:0.8=
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.11.3:4
+ >=gnome-base/libgtop-2.34.0:2=
+ >=gui-libs/libadwaita-1.4:1
+ >=app-misc/tracker-3.0.3:3[vala(+)]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ >=sys-devel/gettext-0.19.8
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}