summaryrefslogtreecommitdiff
path: root/sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild')
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild
new file mode 100644
index 000000000000..611a61497c33
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.11-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="https://untroubled.org/daemontools-encore/"
+SRC_URI="https://untroubled.org/daemontools-encore/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="selinux static"
+
+RDEPEND="
+ !app-doc/daemontools-man
+ !sys-process/daemontools
+ selinux? ( sec-policy/selinux-daemontools )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11-do-not-always-run-tests.patch
+ "${FILESDIR}"/${PN}-1.11-add-missing-setuser-man-page.patch
+ "${FILESDIR}"/${PN}-1.11-implicit-func-decl-clang16.patch
+ "${FILESDIR}"/${PN}-1.11-use-posix-complaint-functions.patch
+)
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake
+}
+
+src_install() {
+ keepdir /service
+
+ echo "${ED}/usr/bin" > conf-bin || die
+ echo "${ED}/usr/share/man" > conf-man || die
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-2 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}