summaryrefslogtreecommitdiff
path: root/sys-process/cronutils/cronutils-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/cronutils/cronutils-1.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/cronutils/cronutils-1.9.ebuild')
-rw-r--r--sys-process/cronutils/cronutils-1.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/cronutils/cronutils-1.9.ebuild b/sys-process/cronutils/cronutils-1.9.ebuild
new file mode 100644
index 000000000000..0c02314fd231
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="https://github.com/google/cronutils"
+SRC_URI="https://github.com/google/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${PN}-version-${PV}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr install
+}