summaryrefslogtreecommitdiff
path: root/sys-process/btop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /sys-process/btop/files
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'sys-process/btop/files')
-rw-r--r--sys-process/btop/files/876319-verbose-makefile.patch54
-rw-r--r--sys-process/btop/files/btop-1.2.13-fix-makefile-deps.patch40
-rw-r--r--sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch27
3 files changed, 67 insertions, 54 deletions
diff --git a/sys-process/btop/files/876319-verbose-makefile.patch b/sys-process/btop/files/876319-verbose-makefile.patch
deleted file mode 100644
index ef2199d728d1..000000000000
--- a/sys-process/btop/files/876319-verbose-makefile.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-# Backport of upstream commit 080a47e6496f12f616b811e0d2f8f36c62d397e2
-# See https://bugs.gentoo.org/876319
-diff --git a/Makefile b/Makefile
-index d1bc95d..6a36c76 100644
---- a/Makefile
-+++ b/Makefile
-@@ -18,6 +18,9 @@ else
- override PRE := info-quiet
- endif
-
-+OLDCXX := $(CXXFLAGS)
-+OLDLD := $(LDFLAGS)
-+
- PREFIX ?= /usr/local
-
- #? Detect PLATFORM and ARCH from uname/gcc if not set
-@@ -53,6 +56,10 @@ ifeq ($(STRIP),true)
- override ADDFLAGS += -s
- endif
-
-+ifneq ($(VERBOSE),true)
-+ override VERBOSE := false
-+endif
-+
- #? Compiler and Linker
- ifeq ($(shell command -v g++-11 >/dev/null; echo $$?),0)
- CXX := g++-11
-@@ -167,8 +174,8 @@ info:
- @printf "\033[1;91mWARNFLAGS \033[1;94m:| \033[0m$(WARNFLAGS)\n"
- @printf "\033[1;94mOPTFLAGS \033[1;94m:| \033[0m$(OPTFLAGS)\n"
- @printf "\033[1;93mLDCXXFLAGS \033[1;94m:| \033[0m$(LDCXXFLAGS)\n"
-- @printf "\033[1;95mCXXFLAGS \033[1;92m+| \033[0;37m\$$(\033[92mREQFLAGS\033[37m) \$$(\033[93mLDCXXFLAGS\033[37m) \$$(\033[94mOPTFLAGS\033[37m) \$$(\033[91mWARNFLAGS\033[37m)\n"
-- @printf "\033[1;95mLDFLAGS \033[1;92m+| \033[0;37m\$$(\033[93mLDCXXFLAGS\033[37m) \$$(\033[94mOPTFLAGS\033[37m) \$$(\033[91mWARNFLAGS\033[37m)\n"
-+ @printf "\033[1;95mCXXFLAGS \033[1;92m+| \033[0;37m\$$(\033[92mREQFLAGS\033[37m) \$$(\033[93mLDCXXFLAGS\033[37m) \$$(\033[94mOPTFLAGS\033[37m) \$$(\033[91mWARNFLAGS\033[37m) $(OLDCXX)\n"
-+ @printf "\033[1;95mLDFLAGS \033[1;92m+| \033[0;37m\$$(\033[93mLDCXXFLAGS\033[37m) \$$(\033[94mOPTFLAGS\033[37m) \$$(\033[91mWARNFLAGS\033[37m) $(OLDLD)\n"
-
- info-quiet:
- @sleep 0.1 2>/dev/null || true
-@@ -252,6 +259,7 @@ btop: $(OBJECTS)
- @sleep 0.2 2>/dev/null || true
- @TSTAMP=$$(date +%s 2>/dev/null || echo "0")
- @$(QUIET) || printf "\n\033[1;92mLinking and optimizing binary\033[37m...\033[0m\n"
-+ @$(VERBOSE) && printf "$(CXX) -o $(TARGETDIR)/btop $^ $(LDFLAGS)\n"
- @$(CXX) -o $(TARGETDIR)/btop $^ $(LDFLAGS) || exit 1
- @printf "\033[1;92m100$(P) -> \033[1;37m$(TARGETDIR)/btop \033[100D\033[38C\033[1;93m(\033[1;97m$$(du -ah $(TARGETDIR)/btop | cut -f1)iB\033[1;93m) \033[92m(\033[97m$$($(DATE_CMD) -d @$$(expr $$(date +%s 2>/dev/null || echo "0") - $${TSTAMP} 2>/dev/null) -u +%Mm:%Ss 2>/dev/null | sed 's/^00m://' || echo '')\033[92m)\033[0m\n"
- @printf "\n\033[1;92mBuild complete in \033[92m(\033[97m$$($(DATE_CMD) -d @$$(expr $$(date +%s 2>/dev/null || echo "0") - $(TIMESTAMP) 2>/dev/null) -u +%Mm:%Ss 2>/dev/null | sed 's/^00m://' || echo "unknown")\033[92m)\033[0m\n"
-@@ -262,6 +270,7 @@ $(BUILDDIR)/%.$(OBJEXT): $(SRCDIR)/%.$(SRCEXT)
- @sleep 0.3 2>/dev/null || true
- @TSTAMP=$$(date +%s 2>/dev/null || echo "0")
- @$(QUIET) || printf "\033[1;97mCompiling $<\033[0m\n"
-+ @$(VERBOSE) && printf "$(CXX) $(CXXFLAGS) $(INC) -MMD -c -o $@ $<\n"
- @$(CXX) $(CXXFLAGS) $(INC) -MMD -c -o $@ $< || exit 1
- @printf "\033[1;92m$$($(PROGRESS))$(P)\033[10D\033[5C-> \033[1;37m$@ \033[100D\033[38C\033[1;93m(\033[1;97m$$(du -ah $@ | cut -f1)iB\033[1;93m) \033[92m(\033[97m$$($(DATE_CMD) -d @$$(expr $$($(DATE_CMD) +%s 2>/dev/null || echo "0") - $${TSTAMP} 2>/dev/null) -u +%Mm:%Ss 2>/dev/null | sed 's/^00m://' || echo '')\033[92m)\033[0m\n"
-
diff --git a/sys-process/btop/files/btop-1.2.13-fix-makefile-deps.patch b/sys-process/btop/files/btop-1.2.13-fix-makefile-deps.patch
new file mode 100644
index 000000000000..4550f3f2cdd1
--- /dev/null
+++ b/sys-process/btop/files/btop-1.2.13-fix-makefile-deps.patch
@@ -0,0 +1,40 @@
+From 0d17fb66c45aa532a26e0e9a3b179d1f57bf037f Mon Sep 17 00:00:00 2001
+From: NexAdn <nex@nexadn.de>
+Date: Thu, 15 Dec 2022 10:04:33 +0100
+Subject: [PATCH] Makefile: make build targets depend on directories
+
+Since directory creation is a requirement for writing the built
+artifacts, this commit introduces a dependency on the directories for
+all build targets (compile and link), so parallel builds can't fail
+because a build target is executed before the directories target.
+
+Closes: https://github.com/aristocratos/btop/issues/479
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ec9f90a..a52929c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -259,7 +259,7 @@ uninstall:
+
+ #? Link
+ .ONESHELL:
+-btop: $(OBJECTS)
++btop: $(OBJECTS) | directories
+ @sleep 0.2 2>/dev/null || true
+ @TSTAMP=$$(date +%s 2>/dev/null || echo "0")
+ @$(QUIET) || printf "\n\033[1;92mLinking and optimizing binary\033[37m...\033[0m\n"
+@@ -270,7 +270,7 @@ btop: $(OBJECTS)
+
+ #? Compile
+ .ONESHELL:
+-$(BUILDDIR)/%.$(OBJEXT): $(SRCDIR)/%.$(SRCEXT)
++$(BUILDDIR)/%.$(OBJEXT): $(SRCDIR)/%.$(SRCEXT) | directories
+ @sleep 0.3 2>/dev/null || true
+ @TSTAMP=$$(date +%s 2>/dev/null || echo "0")
+ @$(QUIET) || printf "\033[1;97mCompiling $<\033[0m\n"
+--
+2.37.4
+
diff --git a/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch b/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch
new file mode 100644
index 000000000000..bf2b1b88dbde
--- /dev/null
+++ b/sys-process/btop/files/btop-1.2.13-verbose-mkdir.patch
@@ -0,0 +1,27 @@
+From c4ee41ebc0f7fabbf4717450c889292464dbeb6d Mon Sep 17 00:00:00 2001
+From: aristocratos <gnmjpl@gmail.com>
+Date: Thu, 15 Dec 2022 17:42:07 +0100
+Subject: [PATCH] Fixed: Makefile, VERBOSE flag now shows directory creation,
+ Issue #480
+
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index a52929c..c746c00 100644
+--- a/Makefile
++++ b/Makefile
+@@ -200,7 +200,9 @@ help:
+
+ #? Make the Directories
+ directories:
++ @$(VERBOSE) || printf "mkdir -p $(TARGETDIR)\n"
+ @mkdir -p $(TARGETDIR)
++ @$(VERBOSE) || printf "mkdir -p $(BUILDDIR)/$(PLATFORM_DIR)\n"
+ @mkdir -p $(BUILDDIR)/$(PLATFORM_DIR)
+
+ #? Clean only Objects
+--
+2.37.4
+