summaryrefslogtreecommitdiff
path: root/sys-process/btop/btop-1.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 19:34:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 19:34:30 +0100
commit948f9476d6a417da6048d4291bf36b0507293d63 (patch)
tree794c4cb065d606084053aeadc0b6a44bce61a6f6 /sys-process/btop/btop-1.2.8.ebuild
parentbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (diff)
gentoo auto-resync : 10:10:2022 - 19:34:30
Diffstat (limited to 'sys-process/btop/btop-1.2.8.ebuild')
-rw-r--r--sys-process/btop/btop-1.2.8.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-process/btop/btop-1.2.8.ebuild b/sys-process/btop/btop-1.2.8.ebuild
deleted file mode 100644
index ee0bbdefbd6d..000000000000
--- a/sys-process/btop/btop-1.2.8.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs xdg-utils
-
-DESCRIPTION="A monitor of resources"
-HOMEPAGE="https://github.com/aristocratos/btop"
-SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
-
-BDEPEND="
- >=sys-devel/gcc-8
-"
-
-pkg_setup() {
- if [[ "${MERGE_TYPE}" != "binary" ]]; then
- if ! tc-is-gcc ; then
- # https://bugs.gentoo.org/839318
- die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
- fi
- fi
-}
-
-src_prepare() {
- default
- # btop installs README.md to /usr/share/btop by default
- sed -i '/^.*cp -p README.md.*$/d' Makefile || die
-}
-
-src_compile() {
- # Disable btop optimization flags, since we have our flags in CXXFLAGS
- emake OPTFLAGS="" CXX="$(tc-getCXX)"
-}
-
-src_install() {
- emake \
- PREFIX="${EPREFIX}/usr" \
- DESTDIR="${D}" \
- install
-
- dodoc README.md CHANGELOG.md
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}