summaryrefslogtreecommitdiff
path: root/sys-process/at/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/at/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/at/files')
-rw-r--r--sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch12
-rw-r--r--sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch22
-rw-r--r--sys-process/at/files/at-3.1.13-getloadavg.patch19
-rw-r--r--sys-process/at/files/at-3.1.13-parallel-make-fix.patch11
-rw-r--r--sys-process/at/files/at-3.1.14-Makefile.patch18
-rw-r--r--sys-process/at/files/at-3.1.8-more-deny.patch20
-rw-r--r--sys-process/at/files/at.pamd-3.1.13-r19
-rw-r--r--sys-process/at/files/atd.confd7
-rw-r--r--sys-process/at/files/atd.rc813
-rw-r--r--sys-process/at/files/atd.service13
10 files changed, 144 insertions, 0 deletions
diff --git a/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
new file mode 100644
index 000000000000..8fd82e639b05
--- /dev/null
+++ b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur at-3.1.10.2.orig/Makefile.in at-3.1.10.2/Makefile.in
+--- at-3.1.10.2.orig/Makefile.in 2009-01-31 15:38:54.000000000 +0100
++++ at-3.1.10.2/Makefile.in 2009-01-31 15:39:22.000000000 +0100
+@@ -78,7 +78,7 @@
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+-lex.yy.c: parsetime.l
++lex.yy.c: parsetime.l y.tab.h
+ $(LEX) -i parsetime.l
+
+ atrun: atrun.in
diff --git a/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
new file mode 100644
index 000000000000..ee24b7f13147
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
@@ -0,0 +1,22 @@
+--- at-3.1.13/configure.ac
++++ at-3.1.13/configure.ac
+@@ -82,10 +82,15 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
+-AC_CHECK_HEADERS(security/pam_appl.h, [
+- PAMLIB="-lpam"
+- AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
+-])
++AC_ARG_WITH([pam], AS_HELP_STRING([--without-pam],
++ [Build without PAM support(default: enabled)]))
++
++if test "x$with_pam" != "xno"; then
++ AC_CHECK_HEADERS(security/pam_appl.h, [
++ PAMLIB="-lpam"
++ AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
++ ])
++fi
+
+ dnl Checking for programs
+
diff --git a/sys-process/at/files/at-3.1.13-getloadavg.patch b/sys-process/at/files/at-3.1.13-getloadavg.patch
new file mode 100644
index 000000000000..7de085dcd84b
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-getloadavg.patch
@@ -0,0 +1,19 @@
+diff --git a/getloadavg.c b/getloadavg.c
+index cf5869f..c7e2b27 100644
+--- a/getloadavg.c
++++ b/getloadavg.c
+@@ -69,8 +69,12 @@ Boston, MA 02110-1301 USA */
+ #include <config.h>
+ #endif
+
+-#include "lisp.h"
+-#include "sysfile.h" /* for encapsulated open, close, read, write */
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
++
++//#include "lisp.h"
++//#include "sysfile.h" /* for encapsulated open, close, read, write */
+
+ #ifndef HAVE_GETLOADAVG
+
diff --git a/sys-process/at/files/at-3.1.13-parallel-make-fix.patch b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
new file mode 100644
index 000000000000..dec02e42310c
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
@@ -0,0 +1,11 @@
+--- at-3.1.13_orig/Makefile.in 2011-06-25 14:43:14.000000000 +0200
++++ at-3.1.13/Makefile.in 2012-03-16 17:23:26.210267660 +0100
+@@ -73,7 +73,7 @@
+ atd: $(RUNOBJECTS)
+ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
+
+-y.tab.c y.tab.h: parsetime.y
++%.tab.c %.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+ lex.yy.c: parsetime.l
diff --git a/sys-process/at/files/at-3.1.14-Makefile.patch b/sys-process/at/files/at-3.1.14-Makefile.patch
new file mode 100644
index 000000000000..1e28619d9a82
--- /dev/null
+++ b/sys-process/at/files/at-3.1.14-Makefile.patch
@@ -0,0 +1,18 @@
+# - install into Gentoo/FHS doc dir
+
+--- at-3.1.14/Makefile.in
++++ at-3.1.14/Makefile.in
+@@ -12,8 +12,11 @@
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+-docdir = $(prefix)/doc
+-atdocdir = $(docdir)/at
++ifndef PF
++PF = at-$(VERSION)
++endif
++docdir = $(prefix)/share/doc
++atdocdir = $(docdir)/$(PF)
+ etcdir = @ETCDIR@
+ systemdsystemunitdir = @systemdsystemunitdir@
+
diff --git a/sys-process/at/files/at-3.1.8-more-deny.patch b/sys-process/at/files/at-3.1.8-more-deny.patch
new file mode 100644
index 000000000000..0a9a7eb2393c
--- /dev/null
+++ b/sys-process/at/files/at-3.1.8-more-deny.patch
@@ -0,0 +1,20 @@
+--- a/at.deny
++++ b/at.deny
+@@ -10,6 +10,8 @@
+ lp
+ mail
+ man
++mysql
++news
+ nobody
+ operator
+ proxy
+@@ -19,6 +21,8 @@
+ qmailq
+ qmailr
+ qmails
++squid
+ sync
+ sys
++uucp
+ www-data
diff --git a/sys-process/at/files/at.pamd-3.1.13-r1 b/sys-process/at/files/at.pamd-3.1.13-r1
new file mode 100644
index 000000000000..5c529c16180e
--- /dev/null
+++ b/sys-process/at/files/at.pamd-3.1.13-r1
@@ -0,0 +1,9 @@
+#
+# The PAM configuration file for the at daemon
+#
+
+auth required pam_env.so
+auth include system-services
+account include system-services
+session include system-services
+
diff --git a/sys-process/at/files/atd.confd b/sys-process/at/files/atd.confd
new file mode 100644
index 000000000000..bd6e4f1d0b88
--- /dev/null
+++ b/sys-process/at/files/atd.confd
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Define startup options for atd(8).
+# For example: ATD_OPTS="-l 3.0 -b 5"
+ATD_OPTS=""
diff --git a/sys-process/at/files/atd.rc8 b/sys-process/at/files/atd.rc8
new file mode 100644
index 000000000000..3cc437eaa16e
--- /dev/null
+++ b/sys-process/at/files/atd.rc8
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/var/run/atd.pid"
+command="/usr/sbin/atd"
+command_args="${ATD_OPTS}"
+start_stop_daemon_args="--pidfile ${pidfile}"
+
+depend() {
+ need clock
+ use logger
+}
diff --git a/sys-process/at/files/atd.service b/sys-process/at/files/atd.service
new file mode 100644
index 000000000000..164fc2c0cb74
--- /dev/null
+++ b/sys-process/at/files/atd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=at (job queue) daemon
+After=networking.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/atd
+PIDFile=/run/atd.pid
+StandardOutput=syslog
+StandardError=syslog
+
+[Install]
+WantedBy=multi-user.target