summaryrefslogtreecommitdiff
path: root/sys-power/thermald/thermald-2.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
commit0e7ef53ddcc33809bcb2644d3649617113b78ea3 (patch)
treef1665ac62e9addb6b2c3663e7f7507b84c82a43e /sys-power/thermald/thermald-2.5.1.ebuild
parent55a7866dd6169a108d3a9e8d6696a970dea8a0b6 (diff)
gentoo auto-resync : 23:09:2022 - 17:30:17
Diffstat (limited to 'sys-power/thermald/thermald-2.5.1.ebuild')
-rw-r--r--sys-power/thermald/thermald-2.5.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-power/thermald/thermald-2.5.1.ebuild b/sys-power/thermald/thermald-2.5.1.ebuild
new file mode 100644
index 000000000000..0bee30caf643
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}