summaryrefslogtreecommitdiff
path: root/sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild b/sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild
new file mode 100644
index 000000000000..2c15af2d8fe2
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="https://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-linux-3.17.patch"
+}
+
+src_compile() {
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}