summaryrefslogtreecommitdiff
path: root/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
index 32bb54180854..4c712c8a69a8 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
@@ -1,10 +1,20 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=0
+
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.busybox.net/uClibc"
- inherit git-2
+
+MY_P=uClibc-${PV}
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://git.busybox.net/uClibc"
+ EGIT_BRANCH="0.9.33"
+ inherit git-r3
+else
+ PATCH_VER="17"
+ SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+ KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -15,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER="17"
- SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
- KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
-fi
LICENSE="LGPL-2"
SLOT="0"
@@ -232,8 +235,8 @@ src_config() {
}
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
else
unpack ${A}
fi