summaryrefslogtreecommitdiff
path: root/sys-libs/timezone-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sys-libs/timezone-data
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sys-libs/timezone-data')
-rw-r--r--sys-libs/timezone-data/Manifest2
-rw-r--r--sys-libs/timezone-data/timezone-data-2021a.ebuild41
2 files changed, 27 insertions, 16 deletions
diff --git a/sys-libs/timezone-data/Manifest b/sys-libs/timezone-data/Manifest
index 72481a7a8264..97eeb40fddd3 100644
--- a/sys-libs/timezone-data/Manifest
+++ b/sys-libs/timezone-data/Manifest
@@ -1,4 +1,4 @@
DIST tzcode2021a.tar.gz 262204 BLAKE2B 4072685f2344602ffcfe32a7bf92d3b0d93e38ffca842f1c07a60db5e26f1f18ab32fc7b5f155b0bdab49f8d0bfcd5b58f4a192b4d06d7d9639893e5cb596328 SHA512 bf1d53bcbfecd3b09d57a9e6d3cb49b5dc5f8e1b6674b67e7f974e1a268c2aaf13ca89a7ef12f49d0665aff782bd72685e00c22a41ca88a028da0429f972fd45
DIST tzdata2021a.tar.gz 411892 BLAKE2B b8d177e90e22bd8a3fd23c9a9c19896cb245efd8e768b59ab8c63e56ab141e67331f3231e3a7c802f844375049cfd902e14e912ce677b3aea38fc0d968905e87 SHA512 7cdd762ec90ce12a30fa36b1d66d1ea82d9fa21e514e2b9c7fcbe2541514ee0fadf30843ff352c65512fb270857b51d1517b45e1232b89c6f954ba9ff1833bb3
-EBUILD timezone-data-2021a.ebuild 5380 BLAKE2B 2f058ece71e2feb8e3db2ad1d09822ec3e32befa081331a2172f451fd84c8674a572aa5433d93294003701bbf94e6bc7d9b8a66d169b5d9f8580b1c9b801ad7b SHA512 a7beca84f4b2d34d602dc68a7a73b0ff64d35e8af4df415e7cbae135bc219d77ab38b62e216c01dbacefb978f7328d9e56a7c68bcec7d5d69950013caf55d6d8
+EBUILD timezone-data-2021a.ebuild 5676 BLAKE2B f9868622cbcb8290fe622a97a81830546c79d4ddecee7b0f9b0022c38a176b9a28e50eccc8d9b2f0518c16202d2febd953cfb431f97c26b9fc14e1c37163c31c SHA512 1a5d9dd6d24a3e333d0c3a6b22cc9b40de85b1ce357b926ee507e4c24117489711bbaa18df7a8b3419feff8fd1e24967ae53136e1457e248b10af9da13175c1f
MISC metadata.xml 728 BLAKE2B b390f4f3d184c7f424d97a36883c9ab67f56a2445d6ecfe6deca69d42864b1249fa2fec6a48bf693f9b2101c167597e5a435cf13a8797784e8f37ad870bf3daf SHA512 36e2c2fa026441ae4b21d33b9425a7195c4d4d404e8f010e9bf894be3095b0d461079a87126f22c398475652777301aa5dcf151b195502d25b4094420c56c7e4
diff --git a/sys-libs/timezone-data/timezone-data-2021a.ebuild b/sys-libs/timezone-data/timezone-data-2021a.ebuild
index 52f5fbdca3bd..b7dce14ae8a4 100644
--- a/sys-libs/timezone-data/timezone-data-2021a.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2021a.ebuild
@@ -150,28 +150,39 @@ configure_tz_data() {
fi
if ! tz=$(get_TIMEZONE) ; then
- einfo "Assuming your empty ${etc_lt} file is what you want; skipping update."
+ einfo "Assuming your empty ${src} file is what you want; skipping update."
return 0
fi
- if [[ "${tz}" == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
- if [[ ! -e "${etc_lt}" ]] ; then
- cp -f "${EROOT}"/usr/share/zoneinfo/Factory "${etc_lt}"
- elog "Setting ${etc_lt} to Factory."
- else
- elog "Skipping auto-update of ${etc_lt}."
- fi
+ if [[ "${tz}" == "FOOKABLOIE" ]] ; then
+ einfo "You do not have a timezone set in ${src}; skipping update."
return 0
fi
- if [[ ! -e "${EROOT}/usr/share/zoneinfo/${tz}" ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your ${etc_lt} has been reset to Factory; enjoy!"
- tz="Factory"
+ local tzpath="${EROOT}/usr/share/zoneinfo/${tz}"
+
+ if [[ ! -e ${tzpath} ]]; then
+ ewarn "The timezone specified in ${src} is not valid."
+ return 1
+ fi
+
+ if [[ -f ${etc_lt} ]]; then
+ # If a regular file already exists, copy over it.
+ ewarn "Found a regular file at ${etc_lt}."
+ ewarn "Some software may expect a symlink instead."
+ ewarn "You may convert it to a symlink by removing the file and running:"
+ ewarn " emerge --config sys-libs/timezone-data"
+ einfo "Copying ${tzpath} to ${etc_lt}."
+ cp -f "${tzpath}" "${etc_lt}"
+ else
+ # Otherwise, create a symlink and remove the timezone file.
+ tzpath="../usr/share/zoneinfo/${tz}"
+ einfo "Linking ${tzpath} at ${etc_lt}."
+ if ln -snf "${tzpath}" "${etc_lt}"; then
+ einfo "Removing ${src}."
+ rm -f "${src}"
+ fi
fi
- einfo "Updating ${etc_lt} with ${EROOT}/usr/share/zoneinfo/${tz}"
- cp -f "${EROOT}/usr/share/zoneinfo/${tz}" "${etc_lt}"
}
pkg_config() {