summaryrefslogtreecommitdiff
path: root/sys-libs/tdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /sys-libs/tdb
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest2
-rw-r--r--sys-libs/tdb/tdb-1.4.5.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index 9e2441872825..14876fee8e9d 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,5 +1,7 @@
DIST tdb-1.4.3.tar.gz 702836 BLAKE2B 6593c3be527b383a7e8fd85b3613cf2429f6b665a7c609a56f57a6f5b41a080c1a681d712afd423c2bc1c741e06d7cd2c90949d9c5bf78ca834b18c64e23d51c SHA512 99488839e7da396f04df60412d21a7d3e09efeab52772d6cb5e9470a3dfd585d73ef2422c51cd0d8ccc123a65d455de400d5d6b24a21a2a50d3da60d9a70e67a
DIST tdb-1.4.4.tar.gz 714367 BLAKE2B fdd84fc76a428b3b98ca481a9ef42c46d21f67f6ca8d92a90e6f0c1d24aa8f1f3b773c8fdcb43b572f8a1441349af491cb5d4ad9440d0b95fb51b89591510e27 SHA512 ef0a997aacebcc804e84ec4a14de8189513ddd1083ba677e421269c21a94f5ca8fc188185645855e5ef81417f4843c8649417ff28f286b768d690907d5d4cb07
+DIST tdb-1.4.5.tar.gz 729650 BLAKE2B 5d8a226cf251268d70f68759fb792628559fa3b10e7843d1a53914ea24f0ceca61fe0c3f348d704ebc8df4c56fe2365690b585b1c96cf53d63ecae1960aca58a SHA512 373b2ce5b2c68fbc28b7679f0e7531115b91ddc6a68b27acada39b995f66b508b19f24d712fc4388654199abd69857e53ebd435d1ed47e3a69ba85ff667fed56
EBUILD tdb-1.4.3.ebuild 1390 BLAKE2B dd53828ff444e148af6dca3f49e3ebda352539e6d6eefa343150159d856ac7c3696e7974a479f4b5aeff96bae69dc66b89c0b57a0b132a772531787ec7c7b8cb SHA512 be7b77a732c8d106dc013e7a1d3b4c51f0c0226cad7fccd14c3886e91ada643bc9c5adf1549315ce008ffc45c2d3191ada3d47ad47accdd99753365f907f2fc7
EBUILD tdb-1.4.4.ebuild 1405 BLAKE2B 8290e5e8a488deeb14238ed5be795b8a763922339448fd62b21f8a6627dce6a58535acee7a0b0e1137477cb8d53fcd530e63b718526227db91438c75893243fc SHA512 b00e032edab9c0392d782e6c3ffcea779fe01363531b7573e664437a5f56054726a645f510669b35f2fc51d09ec744a1e15436d15415546bacf65ee0eb3a5515
+EBUILD tdb-1.4.5.ebuild 1415 BLAKE2B 83de60c8ab49fd019848d687f11693b3b8bb2598f0eee55c2ff7251c34cd4e8cb297150bcd37df9aefe6c04d128823dd74f31cddbe5fcf949c764d07deb4000a SHA512 faf7c7989bb23bbdb61f57e2b42fa100baeaa930e6c240ed8d1cae3622e7437dbceda1595a464c4739a2320851cb2d539ec08b0b664bd1a68e2d64000c3ced46
MISC metadata.xml 244 BLAKE2B d1692c5795a32dd5189e7374f1821bb98cd9efe798e851c04aab69aeab42c100e910d7a4532757f9f83bf1b345aa8e7adcfb3b6dba412dda8d4796313b833958 SHA512 d5cb5e719f70141aa6d7783bb63ebfd6158e9af82700041559c92ed45c688c6162b19a3d1ece204c9bf6cd92f2e7513ef8cc780bd442b312a9a3650a0232a34b
diff --git a/sys-libs/tdb/tdb-1.4.5.ebuild b/sys-libs/tdb/tdb-1.4.5.ebuild
new file mode 100644
index 000000000000..e16b6ec87c6d
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Simple database API"
+HOMEPAGE="https://tdb.samba.org/"
+SRC_URI="https://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python ; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}