summaryrefslogtreecommitdiff
path: root/sys-libs/pam/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /sys-libs/pam/files
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'sys-libs/pam/files')
-rw-r--r--sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch b/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch
new file mode 100644
index 000000000000..5ad7b8c4776e
--- /dev/null
+++ b/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch
@@ -0,0 +1,29 @@
+https://github.com/linux-pam/linux-pam/pull/490
+
+From 5fccc4cbac82b4677af28b59e7a657c86acab7fc Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 11 Sep 2022 16:37:59 +0100
+Subject: [PATCH] configure.ac: fix implicit function declaration in mail spool
+ directory check
+
+Fixes the following error with Clang 15 (which makes implicit function
+declarations an error by default):
+```
++error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+ exit(0);
+ ^
+ note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -297,6 +297,7 @@ if test x$with_mailspool != x ; then
+ else
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <paths.h>
++#include <stdlib.h>
+ int main() {
+ #ifdef _PATH_MAILDIR
+ exit(0);
+