summaryrefslogtreecommitdiff
path: root/sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild')
-rw-r--r--sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild b/sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild
new file mode 100644
index 000000000000..76aff5499f0a
--- /dev/null
+++ b/sys-libs/nss_wrapper/nss_wrapper-1.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-multilib
+
+DESCRIPTION="A wrapper for the user, group and hosts NSS API"
+HOMEPAGE="https://cwrap.org/nss_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}