summaryrefslogtreecommitdiff
path: root/sys-libs/musl/musl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
commitfd1824e9b1fd180f410170bf2d02e1f098f53db9 (patch)
tree7d1346df7be9d29e8e8b2d7bd8c36fe016fd917a /sys-libs/musl/musl-9999.ebuild
parent895ff0a4d41ed3004a73b7869773a26f463c5ded (diff)
gentoo auto-resync : 01:03:2024 - 11:41:16
Diffstat (limited to 'sys-libs/musl/musl-9999.ebuild')
-rw-r--r--sys-libs/musl/musl-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 6034c89cca3e..6f769c7aa732 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -4,7 +4,11 @@
EAPI=8
inherit crossdev flag-o-matic toolchain-funcs prefix
-if [[ ${PV} == "9999" ]] ; then
+
+DESCRIPTION="Light, fast and, simple C library focused on standards-conformance and safety"
+HOMEPAGE="https://musl.libc.org"
+
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
@@ -17,6 +21,7 @@ else
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-musl )"
fi
+
GETENT_COMMIT="93a08815f8598db442d8b766b463d0150ed8e2ab"
GETENT_FILE="musl-getent-${GETENT_COMMIT}.c"
SRC_URI+="
@@ -25,9 +30,6 @@ SRC_URI+="
https://dev.gentoo.org/~blueness/musl-misc/iconv.c
"
-DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="https://musl.libc.org"
-
LICENSE="MIT LGPL-2 GPL-2"
SLOT="0"
IUSE="crypt headers-only split-usr"
@@ -55,12 +57,12 @@ just_headers() {
pkg_setup() {
if [ ${CTARGET} == ${CHOST} ] ; then
case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
esac
fi
- # fix for #667126, copied from glibc ebuild
+ # Fix for bug #667126, copied from glibc ebuild:
# make sure host make.conf doesn't pollute us
if target_is_not_host || tc-is-cross-compiler ; then
CHOST=${CTARGET} strip-unsupported-flags
@@ -118,7 +120,7 @@ src_compile() {
VPATH="${WORKDIR}/misc"
fi
- $(tc-getCC) ${CFLAGS} -c -o libssp_nonshared.o "${FILESDIR}"/stack_chk_fail_local.c || die
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -c -o libssp_nonshared.o "${FILESDIR}"/stack_chk_fail_local.c || die
$(tc-getAR) -rcs libssp_nonshared.a libssp_nonshared.o || die
}
@@ -184,17 +186,17 @@ src_install() {
}
pkg_preinst() {
- # nothing to do if just installing headers
+ # Nothing to do if just installing headers
just_headers && return
- # prepare /etc/ld.so.conf.d/ for files
+ # Prepare /etc/ld.so.conf.d/ for files
mkdir -p "${EROOT}"/etc/ld.so.conf.d
}
pkg_postinst() {
target_is_not_host && return 0
- [ -n "${ROOT}" ] && return 0
+ [[ -n "${ROOT}" ]] && return 0
ldconfig || die
}