summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
index 377022eb4033..6d871c89b6b1 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
@@ -16,16 +16,22 @@ KEYWORDS=""
IUSE="debug static-libs test"
RESTRICT="!test? ( test )"
-RDEPEND="!sys-libs/libunwind"
+RDEPEND="
+ !sys-libs/libunwind
+"
# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-6"
+ >=sys-devel/llvm-6
+"
BDEPEND="
- ${PYTHON_DEPS}
+ !test? (
+ ${PYTHON_DEPS}
+ )
test? (
>=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
- )"
+ )
+"
LLVM_COMPONENTS=( runtimes libunwind libcxx llvm/cmake cmake )
LLVM_TEST_COMPONENTS=( libcxxabi llvm/utils/llvm-lit )