summaryrefslogtreecommitdiff
path: root/sys-libs/libxcrypt/libxcrypt-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/libxcrypt/libxcrypt-2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/libxcrypt/libxcrypt-2.4.ebuild')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-2.4.ebuild b/sys-libs/libxcrypt/libxcrypt-2.4.ebuild
new file mode 100644
index 000000000000..af69e83f0d57
--- /dev/null
+++ b/sys-libs/libxcrypt/libxcrypt-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="A replacement for libcrypt with DES, MD5 and blowfish support"
+SRC_URI="mirror://debian/pool/main/libx/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://packages.debian.org/sid/libxcrypt1"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4-glibc-2.16.patch"
+}
+
+src_configure() {
+ # Do not install into /usr so that tcb and pam can use us.
+ econf --libdir=/$(get_libdir) --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}