summaryrefslogtreecommitdiff
path: root/sys-libs/liburing/liburing-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /sys-libs/liburing/liburing-9999.ebuild
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'sys-libs/liburing/liburing-9999.ebuild')
-rw-r--r--sys-libs/liburing/liburing-9999.ebuild34
1 files changed, 25 insertions, 9 deletions
diff --git a/sys-libs/liburing/liburing-9999.ebuild b/sys-libs/liburing/liburing-9999.ebuild
index 60a614906d8e..ecb77ed5b823 100644
--- a/sys-libs/liburing/liburing-9999.ebuild
+++ b/sys-libs/liburing/liburing-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,14 +12,15 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/axboe/liburing.git"
else
SRC_URI="https://git.kernel.dk/cgit/${PN}/snapshot/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ QA_PKGCONFIG_VERSION=${PV}
fi
LICENSE="MIT"
SLOT="0/2" # liburing.so major version
-IUSE="static-libs"
+IUSE="examples static-libs test"
# fsync test hangs forever
-RESTRICT="test"
+RESTRICT="!test? ( test )"
# At least installed headers need <linux/*>, bug #802516
DEPEND=">=sys-kernel/linux-headers-5.1"
@@ -28,10 +29,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- if [[ "${PV}" != *9999 ]] ; then
- # Make sure pkgconfig files contain the correct version
- # bug #809095 and #833895
- sed -i "/^Version:/s@[[:digit:]\.]\+@${PV}@" ${PN}.spec || die
+ if ! use examples; then
+ sed -e '/examples/d' Makefile -i || die
+ fi
+ if ! use test; then
+ sed -e '/test/d' Makefile -i || die
fi
multilib_copy_sources
@@ -63,5 +65,19 @@ multilib_src_install_all() {
}
multilib_src_test() {
- emake V=1 runtests
+ local disabled_tests=(
+ accept.c
+ fpos.c
+ io_uring_register.c
+ link-timeout.c
+ read-before-exit.c
+ recv-msgall-stream.c
+ )
+ local disabled_test
+ for disabled_test in "${disabled_tests[@]}"; do
+ sed -i "/\s*${disabled_test}/d" test/Makefile \
+ || die "Failed to remove ${disabled_test}"
+ done
+
+ emake -C test V=1 runtests
}