summaryrefslogtreecommitdiff
path: root/sys-libs/libstatgrab/libstatgrab-0.91.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-libs/libstatgrab/libstatgrab-0.91.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-libs/libstatgrab/libstatgrab-0.91.ebuild')
-rw-r--r--sys-libs/libstatgrab/libstatgrab-0.91.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sys-libs/libstatgrab/libstatgrab-0.91.ebuild b/sys-libs/libstatgrab/libstatgrab-0.91.ebuild
index 2e211e2a49ee..8fa5c728d722 100644
--- a/sys-libs/libstatgrab/libstatgrab-0.91.ebuild
+++ b/sys-libs/libstatgrab/libstatgrab-0.91.ebuild
@@ -1,39 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=frob
-inherit autotools-utils
+inherit autotools
DESCRIPTION="A tool to provide access to statistics about the system on which it's run"
HOMEPAGE="https://www.i-scream.org/libstatgrab/"
SRC_URI="https://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2.1 )"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc x86"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
RDEPEND="sys-libs/ncurses"
DEPEND="${RDEPEND}"
DOCS=( ChangeLog PLATFORMS NEWS AUTHORS README )
-PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
src_configure() {
local myeconfargs=(
--disable-setgid-binaries
--disable-setuid-binaries
--with-ncurses
- $(use_enable static-libs static)
+ --disable-static
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
+
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
insinto /usr/share/doc/${PF}/examples